Submitted by : 127.0.0.1 at: 2005-01-26T07:06:51+00:00 (12 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

I'm seeing this error in my event.log, but I don't know if it's serious or not. I'm using ZWiki with Plone 2.0.5.

------ 2005-01-26T01:44:19 ERROR(200) SiteError? http://www.plone4artists.org/development/teams/newsletter/wiki/PloneNewsletter/setskin Traceback (most recent call last): File "/usr/home/jazkarta/zope/274/lib/python/ZPublisher?/Publish.py", line 101, in publish request, bind=1) File "/usr/home/jazkarta/zope/274/lib/python/ZPublisher?/mapply.py", line 88, in mapply if debug is not None: return debug(object,args,context) File "/usr/home/jazkarta/zope/274/lib/python/ZPublisher?/Publish.py", line 39, in call_object result=apply(object,args) # Type s to step into published object. File "/home/jazkarta/zope/instance1/Products/ZWiki/UI.py", line 303, in setskin self.setCMFSkin(REQUEST,Zwiki) File "/home/jazkarta/zope/instance1/Products/ZWiki/UI.py", line 279, in setCMFSkin portal_membership.getAuthenticatedMember().setProperties(REQUEST) AttributeError?: setProperties


comments:

thanks, fixed for 0.38 --simon, Thu, 27 Jan 2005 14:56:34 -0800 reply
Status: open => closed

more detail --simon, Thu, 27 Jan 2005 15:03:52 -0800 reply
More detail, in case this requires a little more thought. The problem was that the plone skin, like the standard skin, now includes several hidden "setskin" links (used for skin switching with the alt _-=+ keys). setskin was giving an error when called by an anonymous user or bot inside a CMF/Plone site. I've made it return harmlessly in this case. This doesn't prevent bots making the extra requests.