Submitted by : 127.0.0.1 at: 2005-01-30T15:19:24+00:00 (12 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

After updating my zwiki site to 0.37 I cannot access the properties page of the zwiki. - Some pages are still accessable, some no longer.:

 Error Type: UnpicklingError
 Error Value: invalid load key, ''.

 zopectl> logtail
     state = unpickler.load()
 AttributeError: 'module' object has no attribute 'ZwikiStxPageTypå'
 ------
 2005-01-30T18:00:54 ERROR(200) ZODB Couldn't load state for 00000000000027eb
 Traceback (most recent call last):
   File "/usr/local/Zope272/lib/python/ZODB/Connection.py", line 562, in setstate    self._set_ghost_state(obj, p)
   File "/usr/local/Zope272/lib/python/ZODB/Connection.py", line 601, in _set_ghost_state
     state = unpickler.load()
 UnpicklingError: invalid load key, ''.


comments:

property change --simon, Sun, 30 Jan 2005 15:22:27 -0800 reply
Category: other => admin-installing

... --simon, Sun, 30 Jan 2005 15:27:04 -0800 reply
Hello.. I think there's more in the logfile that would be useful. Can you tail it and then do what you're doing (accessing the ZMI properties tab of a wiki page ?). Also see if you're getting strange errors with any other kinds of object.

Hi, nice product BTW -- Sun, 30 Jan 2005 16:18:43 -0800 reply
Ok, some pages, backlinks and edit sometimes doesn't work as well. Same two errors in log:

 2005-01-30T18:56:10 ERROR(200) ZODB Couldn't load state for 00000000000027cc
Traceback (most recent call last):
  File "/usr/local/Zope272/lib/python/ZODB/Connection.py", line 562, in setstate    self._set_ghost_state(obj, p)
  File "/usr/local/Zope272/lib/python/ZODB/Connection.py", line 601, in _set_ghost_state
    state = unpickler.load()
AttributeError: 'module' object has no attribute 'ZwikiStxPageTypå'
------
 2005-01-30T18:56:10 ERROR(200) ZODB Couldn't load state for 00000000000027eb
Traceback (most recent call last):
  File "/usr/local/Zope272/lib/python/ZODB/Connection.py", line 562, in setstate    self._set_ghost_state(obj, p)
  File "/usr/local/Zope272/lib/python/ZODB/Connection.py", line 601, in _set_ghost_state
    state = unpickler.load()
UnpicklingError: invalid load key, ''.

When I try setupCatalog I get:

 Error Type: TypeError
 Error Value: 'str' object is not callable

but same error in log:

 2005-01-30T19:08:27 ERROR(200) ZODB Couldn't load state for 00000000000027cc
Traceback (most recent call last):
  File "/usr/local/Zope272/lib/python/ZODB/Connection.py", line 562, in setstate
    self._set_ghost_state(obj, p)
  File "/usr/local/Zope272/lib/python/ZODB/Connection.py", line 601, in _set_ghost_state
    state = unpickler.load()
AttributeError: 'module' object has no attribute 'ZwikiStxPageTypå'

Hi, nice product BTW --Simon Michael, Sun, 30 Jan 2005 18:10:37 -0800 reply
Thanks. I doubt that's a zwiki problem. I would use http://zopewiki.org/lists to search the lists for the kinds of errors you're seeing, scan your ZODB for corruption, etc.

My First POSKey? error -- Sun, 30 Jan 2005 22:01:19 -0800 reply
Well talk about a coincidence it was a corrupt file in the ZODB. You were correct it was not Zwiki but ZODB. I had to do voodoo with the debugger but I blasted the bad Zwiki page and all is well. This ZWiki has been with me since 0.9 and zope 2.4 was new so thanks for everything. Keep up the good work.

My First POSKey? error --simon, Mon, 31 Jan 2005 01:03:33 -0800 reply
Thank you! I like to hear of old wikis humming along.

property change --simon, Mon, 31 Jan 2005 01:04:14 -0800 reply
Category: admin-installing => other Status: open => closed