Submitted by : simon at: 2005-02-04T18:24:20+00:00 (13 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

We have problems providing reliable searching. This is an overview of the general issues. See also #1039 search problems on zwiki.org.

Search is fragile

The currently available zcatalog text indexes are temperamental about the search expressions they accept, and blow up with an error if you enter quotes, too many wildcards, non-ascii characters, the word not, etc. etc.

TING2:

ZCTextIndex?:

TextIndex?:

Search is inconsistent

Search behaviour differs from site to site depending on which catalog indexes are in use and their configuration.

Also, within a single wiki searching happens in a number of different places and they do not all behave the same.

Miscellaneous

A proof that searching for pages containing german umlauts still fails --Wed, 24 Aug 2005 04:55:46 -0700 reply

Try a search for "Äßüö" (which is contained on TschörmänPeydschNeyms)

A proof that searching for pages containing german umlauts still fails --StephanW, Wed, 04 Oct 2006 06:32:16 -0700 reply

Today the problem with german umlauts is, that the zope search does not produce any results (http://zwiki.org/SearchPage?expr=%C3%84%C3%9F%C3%BC%C3%B6) whereas google search does (http://www.google.com/custom?sitesearch=zwiki.org&cof=L%3Ahttp%3A%2F%2Fzwiki.org%2Fmisc_%2FZWiki%2FZWikiPage_icon.gif&site=zwiki.org&q=%C3%84%C3%9F%C3%BC%C3%B6). Unfortunately google search is not available at intranets :(

A proof that searching for pages containing german umlauts still fails --simon, Thu, 12 Oct 2006 11:19:01 -0700 reply

Thanks Stephan. 1036 is an overview issue, so could you open a new issue specifically for the umlaut searching problem, and provide full details of your setup. Here are some things that will be useful: your zope version, your platform, the kind of catalog index you are using, how you have configured it, whether you are using plone or not, whether you can reproduce the problem on zwiki.org or plone.demo.zwiki.org. Thanks!

A proof that searching for pages containing german umlauts still fails --simon, Thu, 12 Oct 2006 11:20:40 -0700 reply

Also: your system's locale, and any locale-related settings in your zope.conf. If any of these things are unclear we can help you find them out later, but provide as much as you know.

... --simon, Thu, 12 Oct 2006 11:22:11 -0700 reply

Category: user-editing => user-browsing Severity: funded => normal

A proof that searching for pages containing german umlauts still fails --simon, Thu, 12 Oct 2006 11:24:54 -0700 reply

PS - as a subscriber, you should be able to do this by sending mail to bugs@zwiki.org if you prefer.

A proof that searching for pages containing german umlauts still fails --StephanW, Mon, 16 Oct 2006 01:00:44 -0700 reply

...created #1298 non-ascii characters in page names are breaking search functionality

sfaf --hsbjyjb, Wed, 28 Sep 2011 01:25:38 -0700 reply

safsafasf