Submitted by : simon at: 2005-02-06T13:46:52+00:00 (12 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :


comments:

no pagenames for blank search on zwiki.org --stefan rank, Sun, 06 Feb 2005 10:32:48 -0800 reply
( and error in my personal zwiki )

Sorry, that I missed the bughunt... As I came today to pick up the new fruit (SearchPage? ;-) I discovered that a blank search gave a long list of no pagenames... (sounds weird) and when I tried to transfer the searchpage to my wiki the funky highlighting in the pagenames did not work at all.

This seems to be caused by the use of:

  <dtml-var "excerptAt(cleanexpr,text=formatWikiname(Title))">

The function excerptAt in my zwiki copy does not take a text argument, but I can see how it would be extended, and testing on zwiki.org (test might highlight) shows that this seems to be done here (but its not in the pullable darcs repo).

The long list of no pagenames is caused by the empty highlight expression (cleanexpr) passed in in this case, which prompts the return of an empty string in excerptAt()

suggestion --stefan rank, Sun, 06 Feb 2005 10:50:49 -0800 reply
I suggest returning an excerpt from the beginning of the text string when the highlight expression is blank. Would that break anything?

suggestion --Simon Michael, Sun, 06 Feb 2005 11:52:46 -0800 reply
Ah, thanks, and sorry I forgot to push. Done.

I suggest returning an excerpt from the beginning of the text string when the highlight expression is blank.

That's what I did.

suggestion --Simon Michael, Sun, 06 Feb 2005 13:32:10 -0800 reply
Yes. That should be fixable in SearchPage? I imagine.

this looks like fixed --betabug, Wed, 14 Feb 2007 03:11:21 -0800 reply
Status: open => closed

can't reproduce any of this, if you believe otherwise please reopen and state why!