Submitted by : 127.0.0.1 at: 2005-02-22T11:37:22+00:00 (12 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

Anytime I add a Zwiki page to my plone site, the pagetitle becomes a site-keyword ('subject' metadata) in the entire plone site.

This makes keywords practically unusable.

There is also a security issue, as this happens regardless of the users role, so anyone who is able to create a wiki page will add keywords, which is supposed to be possible for contentmanagers only.

I run Zope-2.7 on FreeBSD?, with plone 2.0.4 and Zwiki 0.38

remove the 'Subject' function ? --huron, Wed, 23 Feb 2005 09:07:51 -0800 reply

I suggest we just remove the 'Subject' function in CMF.py

remove the 'Subject' function ? --Simon Michael, Wed, 23 Feb 2005 09:16:25 -0800 reply

On Wed, 2005-02-23 at 09:07 -0800, huron wrote:

>I suggest we just remove the 'Subject' function in CMF.py

Ok. I feel it must have been there for some reason, but I can't seem to load this into my brain, so I'm happy with this. Send me a darcs patch so we can blame^H^H^H^H to get your name in the release notes. :). Otherwise I'll do it.

remove the 'Subject' function ? --simon, Thu, 24 Feb 2005 09:11:21 -0800 reply

huron_: existing ZWiki will have to reindex the Subject index so that everything gets clean ...
sm-testing-sucks: ah, so there's a migration issue ? need to do something with catalog if we remove subject ?
sm-testing-sucks: I have to leave this you guys.. I don't have energy for it right now
sm-testing-sucks: I'll apply any patch that fixes it and leaves things clean

partial fix for 0.39 --simon, Tue, 01 Mar 2005 22:04:05 -0800 reply

Wiki pages' Subject now returns '' and no longer generates a lot of keywords in plone. Existing plone sites still must be cleaned up manually by reindexing/replacing portal_catalog's 'Subject' index and metadata.

property change --simon, Tue, 01 Mar 2005 22:04:33 -0800 reply

Category: site-plone.zwiki.org => user-browsing Severity: serious => normal

Returning '' doesn't fix in 0.39 --Wed, 09 Mar 2005 09:17:28 -0800 reply

The entire function needs to be commented out. Returning '' just puts a blank in the Keyword list.

Any news on fixing this? --Fri, 06 May 2005 12:25:13 -0700 reply

This is happening for me, as well, and my users are confused to see all these unintended keywords when they are adjusting the properties for an event or news item. What short-term action can I take that truly eliminates these unwanted keywords? Even Plone Keyword Manager doesn't get rid of them.

Any news on fixing this? --Wed, 25 May 2005 07:43:18 -0700 reply

AFAIK: the only way a keyword can be removed is by removing it from the objects that use it. So I guess you have to upgrade zwiki and then remove the generated keyword from every wiki pages.

someone needs to figure this out --simon, Wed, 25 May 2005 10:18:38 -0700 reply

Severity: normal => serious

resolved ? --simon, Sun, 26 Feb 2006 11:42:42 -0800 reply

I believe current Zwiki has no Subject method and does not generate excessive keywords in plone; and plone sites containing wikis created with older Zwiki versions will still need manual cleanup to remove those old keywords. I don't know how that's done, perhaps plone.org/documentation or #plone does ? I'll assume this is resolved if there's no response.

**(property change) ** --simon, Sun, 26 Feb 2006 12:51:52 -0800 reply

Status: open => closed

another spam revert --betabug, Sat, 03 Mar 2007 18:26:24 +0000 reply

Category: site-zopewiki.org => user-editing Severity: minor => normal Status: open => closed