Submitted by : simon at: 2005-03-11T23:38:26+00:00 (12 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

See also #1036 overview of problems with zwiki's search features.

File "/zope2/Products/ZWiki/CatalogAwareness.py", line 91, in searchCatalog
  if self.hasCatalog(): return self.catalog()(**kw)
File "/zope1/Products/CMFCore/CatalogTool.py", line 266, in searchResults
  return apply(ZCatalog.searchResults, (self, REQUEST), kw)
File "/usr/local/src/Zope-2.7.3-0/lib/python/Products/ZCatalog/ZCatalog.py", line 649, in searchResults
  return self._catalog.searchResults(REQUEST, used, **kw)
File "/usr/local/src/Zope-2.7.3-0/lib/python/Products/ZCatalog/Catalog.py", line 753, in searchResults
  return self.search(args, sort_index, reverse, sort_limit, _merge)
File "/usr/local/src/Zope-2.7.3-0/lib/python/Products/ZCatalog/Catalog.py", line 496, in search
  r = _apply_index(request)
File "/zope1/Products/TextIndexNG2/TextIndexNG.py", line 450, in _apply_index
  resultset = evaluator(parsed_query)
File "/zope1/Products/TextIndexNG2/ParseTree.py", line 125, in __call__
  return self._index.lookupWordsBySubstring(node.getValue())
File "/zope1/Products/TextIndexNG2/TextIndexNG.py", line 588, in lookupWordsBySubstring
  return self._lookup(words, do_autoexpand=0)
File "/zope1/Products/TextIndexNG2/TextIndexNG.py", line 472, in _lookup
  if self.use_thesaurus and self.thesaurus_mode == 'expand_always':
AttributeError: use_thesaurus

switched to ZCTextIndex? --simon, Fri, 11 Mar 2005 23:50:31 -0800 reply

Status: open => closed

repair --frank, Wed, 15 Nov 2006 08:41:11 -0800 reply

Name: '#1068 allina' => '#1068 plone.zwiki.org SiteSearch? UseThesaurusAttribute? Error' Category: admin-customizingskins => site-plone.zwiki.org Severity: wishlist => normal Status: open => closed

... --frank, Wed, 15 Nov 2006 08:41:59 -0800 reply

Name: '#1068 plone.zwiki.org SiteSearch? UseThesaurusAttribute? Error' => '#1068 plone.zwiki.org SiteSearch? UseThesaurus? Attribute Error'

... --frank, Wed, 15 Nov 2006 08:42:43 -0800 reply

Name: '#1068 plone.zwiki.org SiteSearch? UseThesaurus? Attribute Error' => '#1068 plone.zwiki.org SiteSearch? use_thesaurus AttributeError?'