Submitted by : simon at: 2005-05-01T10:36:31+00:00 (12 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

Depending on the order of patches in your repo, it's possible to get this error when pulling:

 $ darcs pull
 Pulling from "zwiki.org:ZWiki"...

 Fail: bug in get_extra.
 Most likely this is caused by a bug that existed in darcs prior
 to version 1.0.1.  Details for dealing with this issue can be found
 at http://www.scannedinavian.org/DarcsWiki/Issues1_2e0_2e1

To fix, you need to recreate your repo as explained at http://www.darcs.net/DarcsWiki/Issues1%2e0%2e1 .


comments:

fixed for me --simon, Sun, 01 May 2005 12:11:44 -0700 reply
Since I had no unpushed local changes, I just did a fresh get from zwiki.org using latest darcs.

closing --simon, Fri, 13 May 2005 20:21:14 -0700 reply
Status: open => closed

Also, darcs on the server has been upgraded to 1.0.3rc1.

property change --simon, Sat, 21 May 2005 10:07:17 -0700 reply
Severity: normal => serious

property change --simon, Sat, 21 May 2005 10:07:52 -0700 reply
Name: #1098 slight darcs corruption => #1098 darcs apply error Fail: bug in get_extra

property change --simon, Sat, 21 May 2005 10:08:22 -0700 reply
Name: #1098 darcs apply error Fail: bug in get_extra => #1098 darcs error Fail: bug in get_extra