Submitted by : simon at: 2005-08-13T01:15:41+00:00 (12 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

Trying to migrate plone.zwiki.org to plone 2.1 failed ("migration did not reach this point"). Limi suggested a forced upgrade from 2.0.5, which shows the error below. See http://plone.org/collector/4468 for more details.

2005-08-13T01:23:25 ERROR ATCT.migration Failed migration for object /plone/Folder.2005-03-28.3311 (CMF Folder\ -> Folder)
Traceback (most recent call last):
File "/zope2/Products/ATContentTypes?/migration/walker.py", line 174, in migrate
migrator.migrate()
File "/zope2/Products/ATContentTypes?/migration/migrator.py", line 195, in migrate
method()
File "/zope2/Products/ATContentTypes?/migration/migrator.py", line 515, in migrate_children
self.new._setObject(id, obj, set_owner=0)
File "/zope2.8.1/lib/python/OFS/ObjectManager?.py", line 265, in _setObject
v=self._checkId(id)
File "/zope2/Products/CMFCore/PortalFolder?.py", line 426, in _checkId
PortalFolderBase?.inheritedAttribute('_checkId')(self, id, allow_dup)
File "/zope2.8.1/lib/python/OFS/ObjectManager?.py", line 84, in checkValidId
raise BadRequest?, (

BadRequest?: The id "outline" is invalid - it is already in use.

2005-08-13T01:23:25 ERROR ATCT.migration FATAL: Migration has failied, aborting transaction!

..even after deleting all outline objects from the site. See also next issue.

property change --simon, Sat, 13 Aug 2005 01:31:35 -0700 reply

Severity: normal => serious

more details --simon, Sat, 13 Aug 2005 02:06:17 -0700 reply

Objects get copied around during migration, and the zwiki page(s) get activated in such a way that they recreate their outline object behind the back of the migration code, confusing it.

likely workaround --simon, Mon, 29 Aug 2005 22:51:27 -0700 reply

Use the ZMI to move your wikis out of the plone site, migrate it, then move them back.

property change --simon, Thu, 01 Sep 2005 13:40:09 -0700 reply

alecm has checked in a fix in ATContentTypes?, also I am including a fix in Zwiki. Either of these should resolve the problem, so either upgrade your Zwiki to 0.45 or greater, or upgrade to the next plone release when it comes out.

fixed in zwiki 0.45 or plone 2.1rc3 --simon, Thu, 01 Sep 2005 15:04:55 -0700 reply

Status: open => closed

repair --frank, Wed, 15 Nov 2006 09:13:01 -0800 reply

Name: '#1143 armin' => '#1143 Problems migrating Plone sites containing wikis to 21' Category: admin-customizingskins => admin-installing Status: open => closed