Submitted by : simon at: 2006-03-08T16:57:23+00:00 (11 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

I think 0.51 does not work with zope 2.7, please confirm. The fix is to change ZWiki/Utils.py line 34 to this:

except ImportError: get_transaction = get_transaction

This kind of backward compatibility code is hard to test except by setting up full-scale multi-zope-version smoke tests.

Or: bitten in the ass by try:except: yet again!

Fix works for me --EmmaLaurijssens, Thu, 09 Mar 2006 13:21:01 -0800 reply

(property change) fixed for 0.52 --simon, Thu, 09 Mar 2006 14:56:48 -0800 reply

Name: '#1222 0.51 fails to initialise with zope < 2.8 ?' => '#1222 0.51 fails to initialise with zope 2.7 ?' Status: open => closed

**(property change) ** --simon, Thu, 09 Mar 2006 16:55:06 -0800 reply

Name: '#1222 0.51 fails to initialise with zope 2.7 ?' => '#1222 0.51 fails to initialise with zope 2.7'

Fix works for me too --terry jones, Thu, 16 Mar 2006 08:18:26 -0800 reply