Submitted by : FrankLaurijssens at: 2007-10-15T07:59:23-07:00 (10 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

This doesn't happen on ZWiki.org, it happens on my private ZWiki within Plone.

When I click on the create button in a wiki page's footer without supplying a page name, I get the form that asks for a page name, type, body and optional comment. Fill it out, and I get a traceback:

 Site Error

 An error was encountered while publishing this resource. 

 AttributeError

 Sorry, a site error occurred. 

 Traceback (innermost last): 

 *      Module ZPublisher.Publish, line 202, in publish_module_standard 
 *      Module ZPublisher.Publish, line 150, in publish 
 *      Module plone.app.linkintegrity.monkey, line 21, in
zpublisher_exception_hook_wrapper 
 *      Module Zope2.App.startup, line 221, in zpublisher_exception_hook

 *      Module ZPublisher.Publish, line 119, in publish 
 *      Module ZPublisher.mapply, line 88, in mapply 
 *      Module ZPublisher.Publish, line 42, in call_object 
 *      Module Products.ZWiki.Editing, line 313, in edit 
 *      Module Products.ZWiki.Editing, line 93, in create 
 *      Module urllib, line 1065, in unquote 

 AttributeError 

 ________________________________

 Troubleshooting Suggestions

 *      The URL may be incorrect. 
 *      The parameters passed to this resource may be incorrect. 
 *      A resource that this resource relies on may be encountering an
error. 

 For more detailed information about the error, please refer to the error log. 

 If the error persists please contact the site maintainer. Thank you for your patience. 


comments:

... --EmmaLaurijssens, Mon, 15 Oct 2007 08:02:18 -0700 reply
Name: '#1391 Footer create button without page name results in AttributeError' => '#1391 Footer create button without page name results in AttributeError?'

That's what they call hypercorrection ;)

Happens outside of plone too --betabug, Mon, 05 Nov 2007 10:34:43 -0800 reply
Just tried on a test zwiki, no plone. The point is that in the form at the bottom of the regular wiki page we don't enter a name, but on the edit/create form we fill in a name and still get the AttributeError.

patch is on the way --betabug, Mon, 05 Nov 2007 10:56:39 -0800 reply
Once it gets through our PatchDiscussion2007 and gets into darcs, we can close this.

should be in darcs now, closing --betabug, Mon, 21 Jan 2008 18:25:32 +0000 reply
Status: open => closed