Submitted by : simon at: 2003-10-26T21:31:38+00:00 (14 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

zwiki@zwiki.org (Wim Bekker) writes:
> I've version 0.10 just installed. When I added a page in the ZMI, Save
> Changes and View the file, my changes are not visible. I have to go to the
> editform, change the contents and click Change to see my changes.


Simon Michael, 2002/09/23 16:29 GMT (via mail):
zwiki@zwiki.org (DeanGoodmanson) writes:
> Wim, That sounds familier. I think that may be a general Zope ZMI
> issue. See my similar question and responses at the top of this page.

Dean, I'd like to know what you're referring to here. Can you explain ?


Simon Michael, 2002/09/25 00:53 GMT (via mail):
zwiki@zwiki.org writes:
> Wim Bekker's problem: I've version 0.10 just installed. When I added a
> page in the ZMI, Save Changes and View the file, my changes are not
> visible. I have to go to the editform, change the contents and click
> Change to see my changes.
>
> I've primarily seen this problem with Squishdot, as I added a link to
> the ZMI tabbed page for editing. I wonder (with help from expert's
> insight) if the ZMI may not be updating that page cache properties
> properly so that the browser isn't refetching the it.


Simon, 2002/09/25 02:43 GMT (via web):
Thanks, fixed for 0.11.


DeanGoodmanson, 2002/09/25 14:20 GMT (via web):
What source file should I look for to see how you fixed this?


2002/09/25 14:59 GMT (via web):
__init__.py (old manage_edit) and ZWikiPage.py (new one). I followed WikiForNow's lead.


DeanGoodmanson, 2002/09/26 20:27 GMT (via web):
Came across an interesting one today. URL'd a /editform on a bare page only to find an older version of the page in the edit box. Related? Hitting /manage got us to the latest copy. (0.11.)


SimonMichael, 2002/09/26 20:48 GMT (via web):
I've seen that with browser caching, had to shift-refresh.