Submitted by : simon at: 2003-10-26T21:31:38+00:00 (14 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

From DeansUpgrade?:

 Expression (Python) Syntax error: 
 invalid syntax

 , for tag < dtml-let e="(ZopeTime() + 365).rfc822()">, on line 21 of UserOptions

 Traceback (innermost last):
  File E:\RLIEng\lib\python\ZPublisher\Publish.py, line 150, in publish_module
  File E:\RLIEng\lib\python\ZPublisher\Publish.py, line 114, in publish
  File E:\RLIEng\lib\python\Zope\__init__.py, line 159, in zpublisher_exception_hook
    (Object: sif)
  File E:\RLIEng\lib\python\ZPublisher\Publish.py, line 98, in publish
  File E:\RLIEng\lib\python\ZPublisher\mapply.py, line 88, in mapply
    (Object: UserOptions)
  File E:\RLIEng\lib\python\ZPublisher\Publish.py, line 39, in call_object
    (Object: UserOptions)
  File E:\RLIEng\lib\python\Products\ZWiki\ZWikiPage.py, line 151, in __call__
    (Object: UserOptions)
  File E:\RLIEng\lib\python\Products\ZWiki\ZWikiPage.py, line 163, in _render
    (Object: UserOptions)
  File E:\RLIEng\lib\python\Products\ZWiki\ZWikiPage.py, line 331, in render_stxprelinkdtmlhtml
    (Object: UserOptions)
  File E:\RLIEng\lib\python\Products\ZWiki\ZWikiPage.py, line 279, in cook
    (Object: UserOptions)
  File E:\RLIEng\lib\python\DocumentTemplate\DT_String.py, line 170, in parse
    (Object: UserOptions)
  File E:\RLIEng\lib\python\DocumentTemplate\DT_String.py, line 223, in parse_block
    (Object: UserOptions)
  File E:\RLIEng\lib\python\DocumentTemplate\DT_String.py, line 170, in parse
    (Object: UserOptions)
  File E:\RLIEng\lib\python\DocumentTemplate\DT_String.py, line 239, in parse_block
    (Object: UserOptions)
  File E:\RLIEng\lib\python\DocumentTemplate\DT_String.py, line 58, in parse_error
    (Object: UserOptions)
 Document Template Parse Error: (see above)


Simon, 2002/09/23 17:13 GMT (via web):
I don't think this is anything to do with zwiki 0.10 or even upgrading, necessarily; I think it's just a broken UserOptions? from an older version of the default wiki content. If that's true then this should already be noted somewhere in the tracker or cvs. (I couldn't find it.)

PS workaround: update your UserOptions? as recommended by UpgradeGuide? & UpgradeGuide?.


2002/09/24 03:51 GMT (via web):

> I think it's just a broken UserOptions? from an older version of the default wiki content.

That was the problem, thanks.

Workarounds mentioned worked. :-) "Let there be green!"


comments:

property change -- Fri, 14 Nov 2003 01:21:23 -0800 reply