Submitted by : simon at: 2003-10-26T21:31:44+00:00 (14 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

Upon freshly installing Zwiki, there are a number of situations that result in Site Errors. E.g., in FrontPage click on the diff link, in the resulting page, click "full history", you will get the following trace back

  Module ZPublisher.Publish, line 150, in publish_module 
  Module ZPublisher.Publish, line 114, in publish 
  Module Zope, line 171, in zpublisher_exception_hook 
  Module ZPublisher.Publish, line 98, in publish 
  Module ZPublisher.mapply, line 88, in mapply 
  Module ZPublisher.Publish, line 39, in call_object 
  Module Shared.DC.Scripts.Bindings, line 252, in __call__ 
  Module Shared.DC.Scripts.Bindings, line 283, in _bindAndExec 
  Module App.special_dtml, line 174, in _exec 
  Module OFS.History, line 116, in manage_change_history 
  TypeError  

2002/11/24 16:31 GMT (weigert, via web):
Above problem occurred on Zope 2.6.0 and Zwiki 0.12.0, with necessary modifications described in ZwikiInstallationOnZope?. Installation on W2K, phyton21.dll version 2.1.18.1010. Python 2.2.1 (#1, Jun 25 2002, 10:55:46)

JustinClift, 2002/11/25 14:59 GMT (via web):
Hi,

Are you able to test it on with Python 2.1.3? That's the recommended version of Python for running Zope with, according to the Zope site.

On my system Python 2.2.x is installed, so it needed a special installation of Python in a subdirectory only made available to the user running Zope. Not sure if the same approach will work on Win2K.

Regards and best wishes,

Justin Clift

weigert, 2002/11/25 15:36 GMT (via web):
I installed Zope from the binary package which included the indicated version of python. I would imagine that the python compiler interpreter included with the official installation would be the correct one to run Zope with?

SimonMichael, 2002/11/26 06:02 GMT (via web):
Understandable, but something isn't right.. I'm pretty sure no released version of zope officially supports python > 2.1.3. Is the binary package from a third party ?

Anyway thanks for this report. I changed the title. I can't reproduce it yet and it doesn't seem to involve zwiki code. I would sanity check it with python 2.1.3 first, also enable verbose logging and look for other problems, like eg running out of memory.

weigert, 2002/11/26 15:14 GMT (via web):
I went back and uninstalled Zope. Then I reinstalled Zope from Zope-2.6.0-win32-x86.exe and installed Zwiki (ZWiki-0.12.0.tgz), and finally made the changes described in ZwikiInstallationOnZope?. (You are correct, the python version now is 2.1.3; I have a theory about python, I had installed plone and that may have added a newer python version?)

The behavior is, unfortunately, still as I had described above. Is there anything stupid that I may be missing, such as enabling versions? Either way, it is not good that installing Zwiki out of the box causes tracebacks.

I am sorry, but I am new to Zope, so any hints on what debugging to undertake to provide more useful feedback would be greatly appreciated.

SimonMichael, 2002/11/26 16:39 GMT (via web):
Sure, we'll narrow it down. Can you create a DTML Document in the zope management interface, then go to it's History tab ?

weigert, 2002/11/26 17:17 GMT (via web):
Did as instructed: Added DTML Document to temp_folder. The View tab shows us a very simple document. The History tab shows us a traceback:

Error Type: TypeError
Error Value: unsliceable object

SimonMichael, 2002/11/27 09:18 GMT (via web):
Let's see the full traceback. If you don't see it on the page, then it should be in the html source. HowToPostATraceback has tips.

weigert, 2002/11/27 10:15 GMT (via web):
Inspecting the document source I find that traceback posted above is the complete traceback.

SimonMichael, 2002/11/27 18:30 GMT (via web):
Hmm, are you running zope 2.6 ? If so perhaps there's more detail in /error_log in the ZMI.

weigert, 2002/11/28 09:19 GMT (via web):
The trace information from /error_log follows below:

Exception traceback
Time 2002/11/26 16:03:53.894 GMT+1 
User Name (User Id) admin (admin) 
Request URL http://localhost:8080/temp_folder/zwiki/FrontPage/manage_change_history_page 
Exception Type TypeError 
Exception Value unsliceable object 

Traceback (innermost last):

Module ZPublisher.Publish, line 98, in publish Module ZPublisher.mapply, line 88, in mapply Module ZPublisher.Publish, line 39, in call_object Module Shared.DC.Scripts.Bindings, line 252, in __call__ Module Shared.DC.Scripts.Bindings, line 283, in _bindAndExec Module App.special_dtml, line 174, in _exec Module OFS.History, line 116, in manage_change_history TypeError: unsliceable object

Display traceback as text

REQUEST form manage_change_history_page full history currentRevision 1

weigert, 2002/11/30 22:01 GMT (via web):
Apparently this is a bug in Zope. When inside the temp_folder there appears to be no history. See http://collector.zope.org/Zope/700 which I submitted describing above experiment suggested by SimonMichael.


comments:

property change -- Mon, 16 May 2005 20:39:27 -0700 reply
Category: general => other Severity: normal => serious