Submitted by : simon at: 2003-10-26T21:31:49+00:00 (14 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

When you install a Zwiki web in a Plone or CMF site you might get a Traceback similar to:

Traceback (innermost last): 

Module ZPublisher.Publish, line 150, in publish_module Module ZPublisher.Publish, line 114, in publish Module Zope.App.startup, line 182, in zpublisher_exception_hook Module ZPublisher.Publish, line 98, in publish Module ZPublisher.mapply, line 88, in mapply Module ZPublisher.Publish, line 39, in call_object Module Products.ZWiki.ZWikiPage, line 218, in __call__ Module Products.ZWiki.CMF, line 73, in __call__ Module Products.CMFCore.utils, line 147, in _getViewFor Not Found

The solution can be found at ZwikiAndPlone and/or Zwiki and Plone.

Tested with Zwiki 0.14 CVS and Plone 1.0beta1.

--PieterB

PieterB, 2002/12/31 10:50 GMT (via web):
This should work out-of-the-box from Plone 1.0 and/or CMF 1.4. How should we accomplish that?

question --SimonMichael, 2003/04/02 16:57 GMT
Hi Pieter - you wrote "The solution can be found at ZwikiAndPlone and/or Zwiki and Plone" here. Was the solution to run the cmf_install_zwiki (Now Install) method ?

working out of the box with cmf/plone --SimonMichael, 2003/04/02 17:05 GMT
CMFQuickInstallerTool should be a step in the right direction (I haven't tried it).

You're asking how to make zwiki types available by default in a new CMF or Plone site without further action ? I'm not sure. The various Plone installer/bundles, which configure lots of products, may be able to do this soon.

CMFQuickInstallerTool --FlorianKonnertz, 2003/05/20 18:40 GMT
I tried CMFQuickInstallerTool inside a CMF site, all recognized products can be checked for installing, but in fact it didn't do anything. - Zope-2.6, ZWiki-0.18,... Still wondering about an easy way to handle all installable products in CMF resp. Plone.


comments:

CMF Quick Installer works for me --Kurt Yoder, Fri, 10 Oct 2003 13:27:25 -0700 reply
Note, look under "Quick Installer", not "CMF Quick Installer" from http://sourceforge.net/projects/collective. Install Quick Installer product, restart Zope. From ZMI add Plone site (and ZWiki of course). In Plone site add quickinstaller product. After this is installed, go to "portal_quickinstaller" in your plone site. Check box next to ZWiki, click "Install". Now wiki folder/page should be available from within Plone site as a Plone product.

*new issue moved to #656 global name p is not defined NameError when adding a page in plone*

cmfboard -- Thu, 30 Dec 2004 00:21:04 -0800 reply