Submitted by : simon at: 2003-10-26T21:32:03+00:00 (14 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

By adding a short amount of code to wikipage.zpt favicons would be displayed at least with mozilla (does not work with internet explorer for me).

Adding:

 <link rel="shortcut icon" type="image/x-icon" href="favicon"
 tal:condition="here/favicon|nothing" />

just after:

 </title>

works for me.

questions --Simon Michael, 2003/05/14 16:26 GMT
Thanks - I actually had saved the same code snippet (from Mailman) for use later.

My favicon questions: Is there any disadvantage to using this everywhere ? When should this or a site icon (/favicon.ico) be preferred ? Is there some useful way we could use both ? What kind of zope object will favicon have to be - a File containing an .ico ? Should this default to the zwiki icon ? Or the current wiki logo ? How do I get rid of the blue background that appears in zwiki.org's current favicon ?

property change --simon, 2003/05/14 16:39 GMT
Severity: normal => wishlist

answers --PieterB, 2003/05/29 10:44 GMT
there is no disadvantage to using this (except it takes some server-processing and a few bytes).

Use /favicon.ico for lame IE 5.5 (and later?) clients that just assume the favicon is located there.

Using both is fine. Just place the favicon.ico in the root of the webserver

... --PieterB, 2003/05/29 11:03 GMT
I think using the microsoft name is the best to do so favicon.ico instead of just favicon.

I used http://www.irfanview.com/ to remove the green colour. You can find it on http://gewis.nl/~pieterb/zope/zwiki-favicon.ico

PieterB

better --SimonMichael, 2003/05/30 12:41 GMT
Thanks Pieter! It appears to have a white background now (still not transparent like some I've seen).


comments:

works apparently --betabug, Tue, 20 May 2008 07:54:58 -0700 reply
Status: open => closed