Submitted by : simon at: 2003-10-26T21:32:11+00:00 (14 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

Here's what I get. Trying to get ZWiki 0.20.0rc1 running under Zope 2.6.1 with recent stable plone. Pages don't display correctly (I see the HTML and markup on the front page) and edit attempts cause this (not the is_issue, er, issue):

This wiki's editform template gave an error.

Traceback (most recent call last):
File "/var/zope/lib/python/Products/ZWiki/UI.py", line 259, in editform
oldid=self.id())
File "/var/zope/lib/python/Shared/DC/Scripts/Bindings.py", line 252, in __call__
return self._bindAndExec(args, kw, None)
File "/var/zope/lib/python/Shared/DC/Scripts/Bindings.py", line 283, in _bindAndExec
return self._exec(bound_data, args, kw)
File "/var/zope/lib/python/Products/PageTemplates/ZopePageTemplate?.py", line 228, in _exec
result = self.pt_render(extra_context=bound_names)
File "/var/zope/lib/python/Products/PageTemplates/PageTemplate.py", line 95, in pt_render
tal=not source, strictinsert=0)()
File "/var/zope/lib/python/TAL/TALInterpreter?.py", line 200, in __call__
self.interpret(self.program)
File "/var/zope/lib/python/TAL/TALInterpreter?.py", line 244, in interpret
handlers[opcode]?(self, args)
File "/var/zope/lib/python/TAL/TALInterpreter?.py", line 703, in do_useMacro
self.interpret(macro)
File "/var/zope/lib/python/TAL/TALInterpreter?.py", line 244, in interpret
handlers[opcode]?(self, args)
File "/var/zope/lib/python/TAL/TALInterpreter?.py", line 726, in do_defineSlot
self.interpret(slot)
File "/var/zope/lib/python/TAL/TALInterpreter?.py", line 244, in interpret
handlers[opcode]?(self, args)
File "/var/zope/lib/python/TAL/TALInterpreter?.py", line 669, in do_condition
self.interpret(block)
File "/var/zope/lib/python/TAL/TALInterpreter?.py", line 244, in interpret
handlers[opcode]?(self, args)
File "/var/zope/lib/python/TAL/TALInterpreter?.py", line 273, in do_startEndTag
self.do_startTag(stuff, self.endsep, self.endlen)
File "/var/zope/lib/python/TAL/TALInterpreter?.py", line 295, in do_startTag
ok, name, s = attrAction(self, item)
File "/var/zope/lib/python/TAL/TALInterpreter?.py", line 363, in attrAction_tal
evalue = self.engine.evaluateText(item[3]?)
File "/var/zope/lib/python/Products/PageTemplates/TALES.py", line 223, in evaluateText
text = self.evaluate(expr)
File "/var/zope/lib/python/Products/PageTemplates/TALES.py", line 217, in evaluate
return expression(self)
File "/var/zope/lib/python/Products/PageTemplates/ZRPythonExpr?.py", line 48, in __call__
return eval(code, g, {})

File "Python expression "here.getFilenameFromRequest('file')"", line 2, in f

AttributeError?: getFilenameFromRequest

... --2003/07/02 06:03 GMT reply

Ack, sorry. This was caused by a really, really old Plone 1.0 beta release. All is well.

yay --SimonMichael, 2003/07/02 08:43 GMT reply

Status: open => closed