Submitted by : simon at: 2003-10-26T21:32:44+00:00 (14 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

I'm using Plone 1.0.5, CMF 1.3.2, Zope 2.6.2

When I click in the history view then to the first version of my page I get the traceback:

 Module ZPublisher.Publish, line 98, in publish
 Module ZPublisher.mapply, line 88, in mapply
 Module ZPublisher.Publish, line 39, in call_object
 Module Products.ZWiki.ZWikiPage, line 281, in __call__
 Module Products.ZWiki.Admin, line 165, in upgrade
 Module ZODB.Connection, line 526, in register
AssertionError

... --SimonMichael, Sun, 12 Oct 2003 20:05:43 -0700 reply

What zwiki version ?

property change --SimonMichael, Sun, 12 Oct 2003 20:06:40 -0700 reply

Title: 'IssueNo0631? ZWiki history first version (createObject) doesn't work...' => 'IssueNo0631? viewing first version in history gives AssertionError?' Severity: serious => normal

this seems to be another example: --simon, Mon, 11 Apr 2005 15:16:46 -0700 reply

Traceback (innermost last):

* Module ZPublisher.Publish, line 175, in publish_module_standard
* Module Products.PlacelessTranslationService.PatchStringIO, line 51, in new_publish
* Module ZPublisher.Publish, line 132, in publish
* Module Zope.App.startup, line 204, in zpublisher_exception_hook
* Module ZPublisher.Publish, line 101, in publish
* Module ZPublisher.mapply, line 88, in mapply
* Module ZPublisher.Publish, line 39, in call_object
* Module OFS.History, line 152, in manage_historyCopy
* Module ZODB.Connection, line 571, in register
AssertionError

So it looks like a zope bug.

property change --simon, Mon, 11 Apr 2005 15:18:08 -0700 reply

Category: user-browsing => other

fixed along the way? closing --betabug, Tue, 17 Jul 2007 02:45:05 -0700 reply

Status: open => closed

Can't reproduce this any more, I believe it has been fixed along the way, so I'm closing it.