Submitted by : 192.168.1.21 at: 2004-01-16T14:38:11+00:00 (13 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

In PageTypes?.py this code

<pre> try:

# start headings at level 2, not 3; will affect all rst clients # XXX not working import docutils.writers.html4zope docutils.writers.html4zope.default_level = 2 import reStructuredText
except ImportError?:
reStructuredText = None DLOG('could not import reStructuredText, will not be available')

</pre>

does the wrong thing because import docutils.writers.html4zope fails. In Zope 2.7 this modules no longer exist. The solution is to import reStructuredText before because it define docutils.writers.html4zope:

<pre> try:

# start headings at level 2, not 3; will affect all rst clients # XXX not working import reStructuredText import docutils.writers.html4zope docutils.writers.html4zope.default_level = 2
except ImportError?:
reStructuredText = None DLOG('could not import reStructuredText, will not be available')

</pre>

property change --Mon, 19 Jan 2004 21:45:45 -0800 reply

Status: open => closed

checked in for 0.27, thank you --simon, Wed, 21 Jan 2004 13:56:34 -0800 reply