Submitted by : SimonMichael at: 2004-05-17T19:37:35+00:00 (13 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

Update: see this comment , also ZopeWiki:VersionsMatrix .

Zwiki 0.30 gives this at startup:

  File "/home/zope-8180-2.5.1-x86/lib/python/Products/ZWiki/Comments.py", line 3, in ?
    import sys, os, string, re, email, email.Errors
 ImportError: No module named email

It requires the email library which is included with python 2.3 (so this issue applies to zope 2.6 as well ?)

It's easy to install python 2.3's email library for python 2.1. But this is unfortunate - 0.30 was supposed to be the release that fixed nagging python 2.1 compatibility issues, after which we could move on. It's not clear what is the latest Zwiki version that is completely compatible out of the box with python 2.1/zope 2.6/2.5.


comments:

Glad to hear it's easy... -- Sun, 06 Jun 2004 07:59:49 -0700 reply
So, for a know-nothing user like myself, how do I get Python 2.3's email library set up in my Zope 2.6.0's private Python 2.1.3 install so that I can get out of ZWiki 0.22 and into ZWiki 0.31?

shane -at- nooro -dot- com

Glad to hear it's easy... --Simon Michael, Sun, 06 Jun 2004 10:30:41 -0700 reply
Essentially: copy the email directory from a python 2.3 distribution to your site-packages or python2.1/lib or wherever it is. I would not recommend this; I would save time and install python 2.3 and zope 2.7. Ping me on irc if you need.

install the email package; >0.32 may not support py 2.1 --simon, Sat, 12 Jun 2004 02:05:24 -0700 reply
Name: 'IssueNo0811? latest releases don't work out of the box with zope 2.5/2.6 ?' => 'IssueNo0811? latest releases don't work out of the box with zope 2.5/2.6' Status: open => closed

needs some clarification --simon, Tue, 13 Jul 2004 10:57:10 -0700 reply
Status: closed => open

fixes --simon, Tue, 13 Jul 2004 11:01:43 -0700 reply
lobbin reported a couple of python 2.3-isms in skin templates, fixed for 0.33.

another one --SimonMichael, Sat, 28 Aug 2004 19:52:55 -0700 reply
IssueNo0897? , fixed for 0.34

what to do --SimonMichael, Sat, 28 Aug 2004 20:15:36 -0700 reply
Zwiki depends on the python 2.3 email package and there's no getting around that. So, this needs to be resolved with documentation I think. Where must it be so users will see it ?

Need more input on irc to knock this off.

more info --SimonMichael, Sat, 28 Aug 2004 22:06:10 -0700 reply
By inspecting release notes and updating ZopeWiki:CompatibilityMatrix , I pronounce that the last Zwiki release that was completely compatible with zope 2.6/python 2.1.3 was: 0.28. Also, 0.34 will be compatible with only the addition of python 2.3's email library, hopefully. If that works out, we will forget about python 2.1 going forward.

property change --SimonMichael, Sat, 28 Aug 2004 22:15:19 -0700 reply
Name: 'IssueNo0811? latest releases don't work out of the box with zope 2.5/2.6' => IssueNo0811 Zope 2.5/2.6 requires Zwiki 0.28, or 0.34 + email lib Category: general => installation Status: open => closed

spam revert --betabug, Wed, 21 Feb 2007 14:14:40 +0000 reply
Category: user-editing-html => admin-installing Severity: funded => normal Status: open => closed

this issue is so old it does not even let me think of a proper joke