Submitted by : simon at: 2004-05-19T12:05:40+00:00 (13 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

This happened when testing setupTracker?pages=1 in plone.zwiki.org:

File "/usr/local/src/Zope-2.7.0/lib/python/ZPublisher/Publish.py", line 100, in publish
  request, bind=1)
File "/usr/local/src/Zope-2.7.0/lib/python/ZPublisher/mapply.py", line 88, in mapply
  if debug is not None: return debug(object,args,context)
File "/usr/local/src/Zope-2.7.0/lib/python/ZPublisher/Publish.py", line 40, in call_object
  result=apply(object,args) # Type s<cr> to step into published object.
File "/zope1/Products/ZWiki/Tracker.py", line 415, in setupTracker
  self.create(page,text=open(dir+page+'.stxdtml','r').read())
File "/zope1/Products/ZWiki/Editing.py", line 100, in create
  p.index_object()
File "/zope1/Products/ZWiki/CatalogAwareness.py", line 121, in index_object
  self.catalog().catalog_object(self, self.url())
File "/zope1/Products/CMFCore/CatalogTool.py", line 235, in catalog_object
  ZCatalog.catalog_object(self, w, uid, idxs)
File "/usr/local/src/Zope-2.7.0/lib/python/Products/ZCatalog/ZCatalog.py", line 513, in catalog_object
  update_metadata=update_metadata)
File "/usr/local/src/Zope-2.7.0/lib/python/Products/ZCatalog/Catalog.py", line 381, in catalogObject
  blah = x.index_object(index, object, threshold)
File "/zope1/Products/TextIndexNG2/TextIndexNG.py", line 223, in index_object
  res += self._index_object(documentId, obj, threshold, attr)
File "/zope1/Products/TextIndexNG2/TextIndexNG.py", line 319, in _index_object
  source = unicode(source, encoding)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xa0 in position 1012: unexpected code byte

That site's portal_catalog uses ZopeWiki:TextIndexNG2 with converters enabled (automatic with plone 2 when TING2 is installed ?). TING2 guesses the tracker pages are HTML and runs its html to ascii converter, but the result cannot be utf-8 encoded. To be continued.

related TING2 bug --simon, Thu, 07 Oct 2004 17:53:27 -0700 reply

http://sourceforge.net/tracker/index.php?func=detail&aid=912175&group_id=50052&atid=458418

workaround --simon, Thu, 07 Oct 2004 17:59:33 -0700 reply

Re-creating plone.zwiki.org's SearchableText index with converters disabled made this error go away. I believe this is a TING2/converter issue.

property change --simon, Thu, 07 Oct 2004 17:59:47 -0700 reply

Category: general => non-zwiki Status: open => closed

property change --simon, Fri, 04 Feb 2005 19:14:18 -0800 reply

Name: '#813 TextIndexNG2? converter causing unicode error when indexing' => '#813 TextIndexNG2? UnicodeDecodeError? during setupTracker'

... --betabug, Tue, 13 Feb 2007 06:15:13 -0800 reply

Name: '#813 jules' => '#813 TextIndexNG2? UnicodeDecodeError? during setupTracker' Status: open => closed