Submitted by : 127.0.0.1 at: 2004-06-04T00:51:11+00:00 (13 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

The render of a ZWiki page fails when TranslationService? (http://zope.org/Members/efge/TranslationService) is installed. I know ZWiki works with PlacelessTranslationService? but I would like to use it on a Zope instance where CPS (http://www.cps-project.org) is installed and CPS use TranslationService?.

Update: this seems to be because TranslationService? & zope 2.7 broke, and there is a way to run zwiki with CPS, see links below.

Error log:

Module ZPublisher.Publish, line 100, in publish
Module ZPublisher.mapply, line 88, in mapply
Module ZPublisher.Publish, line 40, in call_object
Module Products.ZWiki.ZWikiPage, line 239, in __call__
Module Products.ZWiki.ZWikiPage, line 251, in render
Module Products.ZWiki.PageTypes, line 296, in render
Module Products.ZWiki.UI, line 221, in addSkinTo
Module Shared.DC.Scripts.Bindings, line 306, in __call__
Module Shared.DC.Scripts.Bindings, line 343, in _bindAndExec
Module Products.PageTemplates.PageTemplateFile, line 106, in _exec
Module Products.PageTemplates.PageTemplate, line 96, in pt_render
 - <MyPTFile at /mm/wikipage>
Module TAL.TALInterpreter, line 189, in __call__
Module TAL.TALInterpreter, line 233, in interpret
Module TAL.TALInterpreter, line 629, in do_condition
Module TAL.TALInterpreter, line 233, in interpret
Module TAL.TALInterpreter, line 663, in do_useMacro
Module TAL.TALInterpreter, line 233, in interpret
Module TAL.TALInterpreter, line 553, in do_insertTranslation

AssertionError?: (184, 3)

Best regards

Nicolas

gouzy@essi.fr

property change --simon, Sat, 12 Jun 2004 02:06:14 -0700 reply

Category: formatting and rendering => i18n Severity: normal => serious

call for help --simon, Sun, 30 Jan 2005 10:02:50 -0800 reply

I'd like for Zwiki to work with TranslationService? as well, but don't have the time to investigate this. Could someone out there work on it and chat me on #zwiki if you need support.

property change --simon, Sun, 30 Jan 2005 10:03:15 -0800 reply

Severity: serious => wishlist

should either support it or fail gracefully and documentedly --simon, Sun, 30 Jan 2005 10:03:50 -0800 reply

Name: '#838 Render fails whith TranslationService? installed' => '#838 Render fails with TranslationService? installed' Severity: wishlist => serious

cf ZopeWiki:CPSZWiki --simon, Tue, 01 Feb 2005 08:23:46 -0800 reply

property change --simon, Tue, 01 Feb 2005 10:42:54 -0800 reply

Name: '#838 Render fails with TranslationService? installed' => '#838 Zwiki does not work with TranslationService? installed'

a clue --simon, Fri, 14 Oct 2005 08:09:09 -0700 reply

http://mail.zope.org/pipermail/zope-dev/2003-July/020158.html

(property change) downgrading, I don't think this affects many people --simon, Tue, 07 Feb 2006 18:31:14 -0800 reply

Severity: serious => normal

ERP5 --bmenking, Mon, 21 Aug 2006 16:59:04 -0700 reply

Using Zope 2.7.8 and ERP5 in which ZWiki fails. May I suggest upgrading this as ERP5 people can't use ZWiki?

... --betabug, Thu, 22 Feb 2007 16:16:47 +0000 reply

Severity: funded => normal