Submitted by : 127.0.0.1 at: 2004-06-08T00:35:15+00:00 (13 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

Problem's description: In the contentActions tabs in plone 2, accents are not shown correctly (replaced with little squares). For instance : Content Edit etc. becomes : 'Contenu Voir �diter Historique R�troliens'. Other messages (not in the contentActions area) are shown correctly. Translated messages from other products are showing correctly in the contentActions are (plone base documents)

Analysis: The html charset seems to be all right (utf8) and other messages are shown correctly, so the new utf8 encoding for translation file fr.po in not the problem. I guess the little square problem should sound familiar to people used to this kind of problems. It would be usefull to know if people experience this with translations in other languages.

Software version: - Underlying plateform : debian woody - Python 2.3.3 - Zope 2.7 - Plone 2.0.3 (PTS 1.0fork-rc7)

Browsers tested: - Mozilla 1.6 - Mozilla-firefox 0.7 - Konqueror 3.2.2


comments:

this page it self does not show correctly in french (little dots instead of accents) -- Tue, 08 Jun 2004 00:49:46 -0700 reply
This issue page has the same little dots problem in french : I see : Cat�gorie (for Category / in french Catégorie) / S�verit� and so on ...

... --simon, Tue, 08 Jun 2004 11:03:58 -0700 reply
This is #839 CMF/Plone actions translations should happen at view time, not install time. To fix, replace the zwiki actions in portal_actions with the english versions; or pull the latest from CodeRepos and re-install zwiki in plone.

The problem with this page is #846 accented characters in tracker page translations are not displayed correctly. Thanks!

yet another problem --SimonMichael, Wed, 09 Jun 2004 09:55:14 -0700 reply
The accented chars in your comment are broken. They don't seem to be in either utf-8 or iso8859-1 encoding for some reason.

please confirm --simon, Wed, 09 Jun 2004 12:23:33 -0700 reply
Status: open => pending

please confirm - no more french translation with up-to-date (Wed Jun 9 23:54:06) version -- Thu, 10 Jun 2004 01:27:14 -0700 reply
As you suggested, I pulled the last version from darcs (last patch is Wed Jun 9 23:54:06 CEST 2004 simon@joyful.com) and re-installed it ... but now, all the elements that where with little squares are shown in english ... this seems really strange and maybe I've been doing something wrong. If I reinstall the 0.31 tagged version, the interface get translated again, but with the little squares ...

please confirm - no more french translation with up-to-date (Wed Jun 9 23:54:06) version --simon, Thu, 10 Jun 2004 15:06:25 -0700 reply
Ok that makes sense.. like the issue says "I have fixed this in darcs, except I don't see actions being translated yet.".

You can always enter these translations manually in portal_actions for now.

please confirm - no more french translation with up-to-date (Wed Jun 9 23:54:06) version --simon, Thu, 10 Jun 2004 15:09:21 -0700 reply
In case it's not clear, I'm temporarily stumped by this. I see other actions being translated on the fly and I'm not sure why these ones aren't.

duplicate of IssueNo0833? --simon, Fri, 11 Jun 2004 23:53:22 -0700 reply
Status: pending => closed