Submitted by : simon at: 2004-06-10T16:19:50+00:00 (13 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

  Traceback (most recent call last):
  File "/usr/local/src/Zope-2.7.1-b1/lib/python/ZPublisher/Publish.py", line 101, in publish
    request, bind=1)
  File "/usr/local/src/Zope-2.7.1-b1/lib/python/ZPublisher/mapply.py", line 88, in mapply
    if debug is not None: return debug(object,args,context)
  File "/usr/local/src/Zope-2.7.1-b1/lib/python/ZPublisher/Publish.py", line 39, in call_object
    result=apply(object,args) # Type s<cr> to step into published object.
  File "/zope1/Products/ZWiki/Tracker.py", line 350, in setupTracker
    self.create(page,text=open(dir+page+'.stxdtml','r').read())
  File "/zope1/Products/ZWiki/Editing.py", line 99, in create
    p.index_object()
  File "/zope1/Products/ZWiki/CatalogAwareness.py", line 122, in index_object
    self.catalog().catalog_object(self, self.url())
  File "/zope1/Products/CMFCore/CatalogTool.py", line 235, in catalog_object
    ZCatalog.catalog_object(self, w, uid, idxs)
  File "/usr/local/src/Zope-2.7.1-b1/lib/python/Products/ZCatalog/ZCatalog.py", line 528, in catalog_object
    update_metadata=update_metadata)
  File "/usr/local/src/Zope-2.7.1-b1/lib/python/Products/ZCatalog/Catalog.py", line 381, in catalogObject
    blah = x.index_object(index, object, threshold)
  File "/zope1/Products/TextIndexNG2/TextIndexNG.py", line 223, in index_object
    res += self._index_object(documentId, obj, threshold, attr)
  File "/zope1/Products/TextIndexNG2/TextIndexNG.py", line 319, in _index_object
    source = unicode(source, encoding)
  UnicodeDecodeError: 'utf8' codec can't decode byte 0xa0 in position 1534: unexpected code byte


comments:

fixed with latest i18n/l10n I think --simon, Sat, 12 Jun 2004 01:34:40 -0700 reply
Name: IssueNo0847 unicode error with setupTracker in plone => IssueNo0847 unicode error with setupTracker?pages=1 in plone Status: open => closed

happening again.. --simon, Thu, 07 Oct 2004 17:47:12 -0700 reply
Name: IssueNo0847 unicode error with setupTracker?pages=1 in plone => #847 unicode error with setupTracker?pages=1 at plone.zwiki.org Status: closed => open

duplicate of #813 --simon, Thu, 07 Oct 2004 17:48:27 -0700 reply
Status: open => closed