Submitted by : koegler at: 2004-08-07T12:00:29+00:00 (13 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

I have: Zope/(Zope 2.6.1n, python 2.3.3, openbsd3) ZServer?/1.1b1, w/ ZWiki-0-33-0, w/o CMF, w/o Plone

I recently upgraded from ZWiki 0.28 and had a working mail-out. Now I get:

Module ZPublisher.Publish, line 98, in publish
Module ZPublisher.mapply, line 88, in mapply
Module ZPublisher.Publish, line 39, in call_object
Module Products.ZWiki.Editing, line 196, in comment
Module Products.ZWiki.Mail, line 600, in sendMailToSubscribers
Module Products.ZWiki.Mail, line 647, in sendMailTo
Module Products.ZWiki.Mail, line 469, in fromHeader

AttributeError: usersEmailAddress

the code at this place (Mail.py:469) is:

address = (self.fromProperty() or

           self.usersEmailAddress() or

           self.replyToProperty())

there's no other reference to usersEmailAddress in Mail.py

Workaround - comment the offending line:

#self.usersEmailAddress() or

I suspect this relates to the absence of CMF or Plone (nothing in the code explicitly states this), but I can't verify this right now.

(new) --Simon Michael, Sat, 07 Aug 2004 13:53:47 -0700 reply

>Workaround - comment the offending line:: > > #self.usersEmailAddress() or > >I suspect this relates to the absence of CMF or Plone (nothing in the code explicitly states this), but I can't verify this right now. > Oops - I left this code for a while and I guess I hadn't finished after all. I've checked in the same fix, thanks.

property change --simon, Sat, 07 Aug 2004 15:20:43 -0700 reply

Severity: normal => serious Status: open => closed