If you want to hide and disable the "upload file or image" interface from the edit form, then follow these steps:

Of course if all you want is to unclutter your Zwiki folder from the uploaded files, you can add the "uploads" folder without changing the permissions on it. In that case all uploads will go into that folder.

... --Simon Michael, Thu, 08 Mar 2007 00:57:05 +0000 reply

On Wed, 2007-03-07 at 22:32 +0000, betabug wrote:

> If you want to hide and disable the "upload file or image" interface > from the edit form

If that's the only goal, you can just deny Add Documents, Images, and Files on your wiki folder. No need to add an "uploads" folder, which is just a convenience for folks who want to keep files separate from wiki pages.

Opposite? --finrod, Mon, 12 Mar 2007 19:36:37 +0000 reply

I have the situation where users don't get the attach box to appear on the edit screen. Can you think of why that would be? I've looked at permissions, but didn't see what was wrong. People with Manager rights do see the box, but regular users do not.

finrod

attachment box missing? --finrod, Tue, 13 Mar 2007 02:18:56 +0000 reply

I have the opposite problem - the attachment box is missing for all users except managers. How do I this fix problem?

Opposite? --betabug, Tue, 13 Mar 2007 08:24:18 +0000 reply

Finrod, you will have to work from the opposite direction here.

It depends on what "role" the people without Manager rights have. You will have to explicitly check on the "Add Documents, Images, and Files" permission for that role - in the security tab for the folder of the Zwiki. Also make sure there is no folder (or other object) with id "uploads" in your Zwiki folder - and if there is such a folder, make sure the "Add Documents, Images, and Files" permission is on for the role in question too.

What that role is depends on your setup. If anybody can edit (including anonymous users), then you need to give anonymous that permission too. That might be a dangerous step, depending on your setup and the openness/control situation of your wiki.

no luck --finrod, Fri, 01 Jun 2007 12:23:01 -0700 reply

I tried this and still no luck. The users have manager role and I checked all the boxes in ZMI and unchecked the acquire role and still they cannot see the attachment box. Can you think of anything else I can change.

no luck --EmmaLaurijssens, Fri, 01 Jun 2007 12:47:30 -0700 reply

I'd almost say, create a separate wiki and do some experiments, if necessary in another Zope.

BTW, are you running Zwiki directly on Zope or within a Plone site? And, which versions do you use?

no luck --finrod, Tue, 05 Jun 2007 20:01:03 -0700 reply

Hi Frank,

Yes - that's what I did. I created a basic plone site (zope 296; plone 2.5.3; zwiki 0.59) and I try the above and I can't see the upload box unless the user is a manager in the plone site. I could try in plain zope too I suppose...

fin

no luck --EmmaLaurijssens, Wed, 06 Jun 2007 08:46:06 -0700 reply

Ah, I see. Issue #1284 is still open, I'm afraid.

no luck --finrod, Wed, 06 Jun 2007 09:39:09 -0700 reply

ah - yes that is it. Will post some things over there. I don't care if everyone posts files so I think I'll just look at how to modify the template to not check the permissions at all.

no luck --finrod, Wed, 06 Jun 2007 09:40:08 -0700 reply

ah geez...IC I posted about this over there is september...d'oh...

no luck --Simon Michael, Wed, 06 Jun 2007 09:42:48 -0700 reply

I know the feeling..