I tend to forget the details of how i18n works.

Problem: i18n/zwiki.pot is out of date, eg because text has been changed in the code or skin templates. This means po files are also out of date and translators can't add translations for the latest text strings.

Solution: Makefile hints, vaguely:

# remember: 1. merge source files 2. make pot 3. replace po files 4. make po
# using zope 3's i18nextract.py with zopewiki/ZopeInternationalization patches

There is also the standalone http://www.infrae.com/download/i18nextract-sa/ which I haven't tried yet. Here's how to use the zope 3 i18nextract.

  1. Install the latest zope 3 source. Zwiki Makefile assumes it is in /usr/local/src.
  2. Get the patch from http://zopewiki.org/i18nextract and apply it with 'patch -p0 <patch' in the zope 3 directory.
  3. Build zope 3 by running 'make'. You'll need a complete python installation ('python2.3-dev' package).
  4. Make a 'principals.zcml' eg by copying 'sample_principals.zcml'
  5. In the zwiki directory, 'make pot'

not quite --simon, Sat, 30 Apr 2005 08:19:20 -0700 reply

#1093. Compare the "old Defaults patch":/zwikidir/misc .

Unable to apply patches --nachtigall, Thu, 11 Aug 2005 07:15:59 -0700 reply

Hi simon, I cannot apply the patches from http://zopewiki.org/i18nextract . E.g. i18nextract-update-defaults.patch talks about a file named src/zope/app/locales/extract.py . I cannot find such a file -- actually cannot even find the dir "src":

<pre> jens@schlepptop:/usr/local/src/ZopeX3?-3.0.1$ find -name "src" jens@schlepptop:/usr/local/src/ZopeX3?-3.0.1$ </pre>

new process --simon, Wed, 06 Feb 2008 20:01:45 -0800 reply

make pot now requires i18ndude, which is much simpler to run. You'll need a version newer than 2008/2/6.