Add new problems at the bottom; see also InstallationProblemsArchive


So ... to go from 0.9.2 to 0.9.3 do I need to do anything special? I'm worried about the extra properties and the RecentChanges? upgrade you had to do here ...

In theory, no. Everything should just work. --SM

And everything did. So I bravely installed 0.9.3 on top of a bare zope 2.3.2-linux2-x86 box at work ... but I got a great deal of "this product broken ...". My own silly fault, of course - untarred into a directory called Zwiki instead of ZWiki ... all fine now ...


object is not callable

Goal is to move old Zwiki0.6.1 folder to Zope2.4 and Zwiki0.9.5. Installed fresh zope, then old zwiki. Imported existing zwiki folder. Got it to work fine. Installed new zwiki code. I can view pages, view RecentChanges?, do a search. But if I hit the Edit this page link, I get:

 Error Type: TypeError
 Error Value: object is not callable: 'TestNewPage'

With traceback:

  File C:\Zope\ZWIKIM~1\lib\python\ZPublisher\Publish.py, line 223, in publish_module
  File C:\Zope\ZWIKIM~1\lib\python\ZPublisher\Publish.py, line 187, in publish
  File C:\Zope\ZWIKIM~1\lib\python\Zope\__init__.py, line 226, in zpublisher_exception_hook
    (Object: TestNewPage)
  File C:\Zope\ZWIKIM~1\lib\python\ZPublisher\Publish.py, line 171, in publish
  File C:\Zope\ZWIKIM~1\lib\python\ZPublisher\mapply.py, line 160, in mapply
    (Object: editform)
  File C:\Zope\ZWIKIM~1\lib\python\ZPublisher\Publish.py, line 112, in call_object
    (Object: editform)
  File C:\Zope\ZWIKIM~1\lib\python\Products\ZWiki\ZWikiPage.py, line 657, in editform
    (Object: TestNewPage)
  File C:\Zope\ZWIKIM~1\lib\python\OFS\DTMLMethod.py, line 194, in __call__
    (Object: editform)
  File C:\Zope\ZWIKIM~1\lib\python\DocumentTemplate\DT_String.py, line 546, in __call__
    (Object: editform)
  File C:\Zope\ZWIKIM~1\lib\python\DocumentTemplate\DT_Util.py, line 231, in eval
    (Object: standard_wiki_header(this(),REQUEST,RESPONSE,title_url='../'+id()))
    (Info: this)
  File <string>, line 2, in f
TypeError: (see above)

If I Add a new zwiki web, I can edit any page fine. Is this a "delete the old DTML methods" case associated with moving from a pre-0.7 version? If so, what exactly does that mean? I should actually delete all the DTML objects in the folder, and there's code within the Product that will do that for me? Then why do the DTML objects even exist? To make them easier to tweak for style?

-- BillSeitz Oct9, 2001

Bill - I don't remember the details right now but the api used by the various dtml support methods has changed since you created your wiki. In your shoes I would delete the zwiki pages from a new, working wikiweb, then copy & paste all your old zwiki pages into that folder. --SM

Simon, when I try this I seem to lose parents properties, at least sometimes (getting rather inconsistent results, my favorite). --BS


can't set UserOptions?

When I hit the Save Cookie button, I get an error about:

 Error Type: KeyError
 Error Value: zwiki_height

With a little work, I discover that if I view source on the form, I find

 Edit form width: 
 height: 

But when I look at the DTML for the form, it looks fine. So it looks like something is doing some nasty rendering of the _ into u tags. --BillSeitz

I've heard this mentioned in connection with zope 2.4 and/or StructuredTextNG --SM


Additional remark to "can't set UserOptions?", Flynt 2001/10/18

Using ZWiki-0-9-5: I experience the problem described above (Key error when trying to "Save Cookie" in UserOptions?) on Zope 2.4.1. However it works fine with Zope 2.3.3! This confirms the remark that the problem is related to Zope 2.4 and/or StructuredTextNG.


Broken UserOptions? in combination with Zope 2.4, Flynt 2001/11/10

It seems that it will work again with Zope 2.4.3. I tried with ZWiki 0.9.6 on Zope 2.4.3beta1 and UserOptions? was fine again.

Simon Michael <simon@joyful.com>, Sat, 10 Nov 2001 12:24:27 -0800 (via mail):
Excellent, thanks for the report.

Novice ZWiki user running ZOPE 2.3.2 under Windows 2000. I installed the CMF1.1 some time ago and it works fine. Tried the ZWiki, followed instructions and also installed ZWikiWebs?.zexp as directed, no problems. Tried to add a page to the Frontpage and get Attribute Error, Index_error. Traceback as follows:

Traceback (innermost last): File C:\PROGRA~1\TRANSACT\lib\python\ZPublisher?\Publish.py, line 223, in publish_module File C:\PROGRA~1\TRANSACT\lib\python\ZPublisher?\Publish.py, line 187, in publish File C:\PROGRA~1\TRANSACT\lib\python\Zope\__init__.py, line 221, in zpublisher_exception_hook (Object: FrontPage) File C:\PROGRA~1\TRANSACT\lib\python\ZPublisher?\Publish.py, line 171, in publish File C:\PROGRA~1\TRANSACT\lib\python\ZPublisher?\mapply.py, line 160, in mapply (Object: edit) File C:\PROGRA~1\TRANSACT\lib\python\ZPublisher?\Publish.py, line 112, in call_object (Object: edit) File C:\PROGRA~1\TRANSACT\lib\python\Products\ZWiki\ZWikiPage.py, line 942, in edit (Object: FrontPage) File C:\PROGRA~1\TRANSACT\lib\python\Products\ZWiki\ZWikiPage.py, line 693, in create (Object: FrontPage) AttributeError?: (see above)

Any ideas ?

andrew.slade@sunderland.ac.uk Thanks.


2002/05/01 14:38 GMT (via web):
OK...I installed Zope 2.5 and zwiki 0.9.8 and everything seems to work ok except that email notification does nothing.

Is there some magic that the Zope admin need to make before email notices get sent out when pages change?

TIA, Sam


comments:

email -- Mon, 07 Feb 2005 10:20:58 -0800 reply