Old InstallationProblems are moved here, most recent at the bottom.


Upgrading

I don't know what that's about. Can you send me the error traceback ? View source to see it - Also, after installing the .2 version, I still need to give anonymous users view management access.

Hmm, I'm pretty sure I don't. It's hard to say what's going on, I would try to remove all traces of the ZWiki product & folders from your zope server & start afresh with the latest version, following ZWikiInstallation?. Let me know if that helps.

Graham 99/11/09

Deleting all the old Zwiki stuff, and reinstalling seems to have fixed it all!

Thanks.


Is there more than one version of ZWiki-0.3? The one I have does not have such headers and footers. --Ross

Have you imported the sample wiki ? (ZWikiInstallation?) --SimonMichael

That did the trick. --Ross (added this after it was put in the archive)


The Catalog in the sample wiki web has export/ prepended to each of the ZWikiPage objects in the Catalog. If one imports the sample wiki web using the zwiki.zexp file into the root folder as suggested in ZWikiInstallation?, trying to modify the page via it's edit link causes an "Uncatalog" error. To fix this I had to clear all objects from the catalog and use the Find tab of the Catalog to get the ZWikiPage objects back into the catalog.

This happened to me as well. I'm a zope newbie so I thought it was me somehow (whew). I think the wikiweb concept is mind-boggling.

I am even newer newbie and when you said to clear all objects I thought that meant to delete them from the database. This is wrong; what you have to do is go to the Catalog page and delete the pages from the catalog (not the whole database) and then find them again.

thanks, removed catalog code for the moment --SM


When I try to import zwiki.zexp as instructed by ZWikiInstallation?, I get this error. I'm using the latest packaged versions of Zope and ZWiki. Any ideas?

                                  The object zwiki does not support this operation

Ok

Powered by Zope-[ZopeButton] Traceback (innermost last): File /home/deltab/zope/Zope-2.1.6-linux2-x86/lib/python/ZPublisher/Publish.py, line 214, in publishmodule File /home/deltab/zope/Zope-2.1.6-linux2-x86/lib/python/ZPublisher/Publish.py, line 179, in publish File /home/deltab/zope/Zope-2.1.6-linux2-x86/lib/python/Zope/__init_.py, line 202, in zpublisher_exception_hook (Object: ElementWithAttributes) File /home/deltab/zope/Zope-2.1.6-linux2-x86/lib/python/ZPublisher/Publish.py, line 165, in publish File /home/deltab/zope/Zope-2.1.6-linux2-x86/lib/python/ZPublisher/mapply.py, line 160, in mapply (Object: manage_importObject) File /home/deltab/zope/Zope-2.1.6-linux2-x86/lib/python/ZPublisher/Publish.py, line 102, in call_object (Object: manage_importObject) File /home/deltab/zope/Zope-2.1.6-linux2-x86/lib/python/OFS/ObjectManager.py, line 485, in manage_importObject (Object: ElementWithAttributes) File /home/deltab/zope/Zope-2.1.6-linux2-x86/lib/python/OFS/CopySupport.py, line 377, in _verifyObjectPaste (Object: ElementWithAttributes) Copy Error: (see above)

--[deltab]?

no response, presumed resolved --SM

Check to make sure you are importing into the Control Panel / Products folder --Anon


How do you upgrade from ZWiki 0.3 to ZWiki 0.4 if you already have lots of content in the 0.3 ZWiki site? Do you have to manually export (one by one) every object from the old folder and then import to the new folder?

-ross.attrill@de.com.au

back up everything. Then, install the latest version of the zwiki product and use your old wiki site as before. Zwiki should transparently adapt your old pages where needed --SM


I'm trying to install ZWiki 0.7.0 on an extant Zope setup. The python appears to install fine, but I can't import the ZWikiWebs?.zexp file! I get the following error from the Zope management screens...

The object ZWikiWebs does not support this operation

any ideas? --PhilArmstrong

Yes - are you importing in /Control_Panel/Products ? --SM

Aha. Clearly a case of failing to RTFM properly. Apologies! --PhilArmstrong

I have the same problem. I don't see /Control_Panel/Products in my manage tree anywhere. What gives? --SkipMontanaro

do you have full manage access to your zope installation ? or only to a subtree ? --SM


I had an existing Zwiki 0.6.1 (or maybe 0.7.1--see below) install on Zope 2.2.0 (on NT). I ran into a couple problems or oddities after upgrading to 0.7.0. I should mention that I did not delete my old zwiki examples folder before importing the new zexp file.

1) The icon references are pointing into the void. For example, FrontPage in the classic wiki has an icon with a URL of http://localhost:8080/misc_/ZWiki/ZWikiPage_icon. For reference, the page is in http://localhost:8080/zwiki_examples/classic_wiki. Even stranger, when I go to the FrontPage of the wiki I created earlier (named basic_wiki) the icon is broken. If I click on the FrontPage on the top I get the backreferences page, with another broken icon. But if I hit the back button on my browser (MSIE 5) I see a good icon on the original page.

2) Hitting the edit link on the multiple markup (even in the zwiki examples) produces the error

Error Type: TypeError
Error Value: call of non-function (type string)
-- RossBoylan

*Yes - maybe I should have made it clearer that pre-0.7.0 DTML methods will not work with this release, due to api enhancements, 2.2-style product initialization, etc. So for an existing pre-0.7.0 wiki web, you can either 1. delete all your DTML methods and let zwiki supply defaults or 2. compare your methods with those from the sample wikis and make just the necessary changes. Hope this helps --SM*

Well, it's working, but there are a number of puzzles:


I've installed ZWiki-0.7.1 into a Zope 2.2.2 system and imported into the Control_Panel/Products folder.

Then trying to create a ZWikiWeb? from the popup, I get the following error after pressing the Create ZWiki Web button.

Error Type: KeyError
Error Value: H?v`H?v$yh?-----------------------------15371958232645 Content-Disposition: form-data; name="wiki_type" dtml

The thing is this happens with ZWiki-0.7.0 as well. Is there a chance I'm missing installing something?

cheers, TonyMcDonald.

No clue about this Tony. No, ZWiki/ZWikiWebs? don't rely on anything else being installed. In your shoes I would 1. De-install both products completely and try again 2. See if it happens in a brand new Data.fs 3. post the traceback here or to the zope list. --SM

I have a traceback now - it looks like a problem with form data. I still can't reproduce it myself. Could it be specific to IE on Mac ? --SM

update: apparently, it is a problem with mac-IE. See also mailing list thread. I don't know of a solution but here's an emergency workaround for you mac users: copy the desired wiki from /Control_Panel/Products/ZWikiWebs? to wherever you want it. --SM


I'm getting something similar when I try the Create ZWiki Web except that the error message is TypeError unhashable type. I'm using python-1.5.2-12 and am doing the install from scratch (pray forgive the detail):
zcat Zope-2.2.2-src.tgz | tar xf -
cd Zope; mkdir Products; cd Products
zcat ~/src/ZWiki-0.7.1.tgz | tar xf -
cp ZWiki/*.zexp ../imports
python ./wo_pcgi.py
make
./start

Create management user. I import the ZWikiWebs?.zexp into the Control Panel/Products and then try to create a ZWiki Web off of the root. No matter what type I try to create, I get the TypeError.

Traceback (innermost last):
  File /home/ggodfrey/src/Zope-2.2.2-src/lib/python/ZPublisher/Publish.py, line 222, in publishmodule
  File /home/ggodfrey/src/Zope-2.2.2-src/lib/python/ZPublisher/Publish.py, line 187, in publish
  File /home/ggodfrey/src/Zope-2.2.2-src/lib/python/Zope/__init__.py, line 221, in zpublisher_exception_hook (Object: RoleManager)
  File /home/ggodfrey/src/Zope-2.2.2-src/lib/python/ZPublisher/Publish.py, line 171, in publish
  File /home/ggodfrey/src/Zope-2.2.2-src/lib/python/ZPublisher/mapply.py, line 160, in mapply (Object: ZWikiWebAdd)
  File /home/ggodfrey/src/Zope-2.2.2-src/lib/python/ZPublisher/Publish.py, line 112, in call_object (Object: ZWikiWebAdd)
  File /home/ggodfrey/src/Zope-2.2.2-src/lib/python/OFS/DTMLMethod.py, line 172, in __call__ (Object: ZWikiWebAdd)
  File /home/ggodfrey/src/Zope-2.2.2-src/lib/python/DocumentTemplate/DT_String.py, line 528, in __call__ (Object: ZWikiWebAdd)
  File /home/ggodfrey/src/Zope-2.2.2-src/lib/python/DocumentTemplate/DT_With.py, line 133, in render (Object: manage_clone(.getitem(REQUEST['wiki_type']),REQUEST['newid'],REQUEST))
  File /home/ggodfrey/src/Zope-2.2.2-src/lib/python/DocumentTemplate/DT_Util.py, line 337, in eval (Object: manage_clone(.getitem(REQUEST['wiki_type']),REQUEST['new_id'],REQUEST)) (Info: manage_clone)
  File , line 0, in ?
TypeError: (see above)

Any help would be appreciated!

--GaryGodfrey (ggodfrey@io.com), Austin TX

hmmm.. by me also --SM

Note: I've figured out how to make it work - create the Zwiki Web off of a new folder rather than the root. I'm leaving the description up for now in case it helps someone else. --gg.


I've installed ZWiki-0.7.1 into a Zope 2.2.2 system and imported .zexp file <snip> Error Type: AttributeError?
Error Value: standard_frameset

I believe you have installed ZwikiWithFrames. See RossBoylan's similar issue above. --SM


Installation problem: after restart ZServer? I can see "ZWiki (Broken product ZWiki)" in "/Control_Panel/Products"and the next lines:

Traceback (innermost last):
File "/usr/lib/zope/lib/python/OFS/Application.py", line 387, in
import_products
product=__import__(pname, global_dict, global_dict, silly)
File "/var/lib/zope/Products/ZWiki/__init__.py", line 6, in ?
import ZWikiPage
File "/var/lib/zope/Products/ZWiki/ZWikiPage.py", line 49, in ?
from AccessControl? import getSecurityManager
ImportError?: cannot import name getSecurityManager

Ok, i need zope 2.2


Zwiki on debian (potato / zope v2.1.6)

What a mess! I just found the time to grab zope for my private potato box. And well zwiki won't work :( Zwiki Product is broken and complains about:

  from AccessControl import getSecurityManager 
  ImportError: cannot import name getSecurityManager

So what should i do? Start fixing stuff or grab zope v??? from unstable/testing? Any recommendations experiences someone? Thanks! --BeWo 13mar2001

Yes - zwiki 0.7 and greater requires zope 2.2 or greater. I think you could grab zope-2.2.4 from woody --SM


seealso keyerror with zwikiwebs 0.9.2

Attempted to install and use Zwiki 0.9.2 to get around the vhosting problems. Took some fiddling with a combination site access rule and siteroot - I'll document that somewhere on zwiki.org when I get GreenCheese? healthy. Anyway, when setting up a zwikidotorg style wiki I got:

Error Type: KeyError? Error Value: seealso

My apologies, this experimental zwiki.org feature crept in to the release. Just remove the <dtml-var seealso> from your standard_wiki_footer.

To fix this for new wikis, do the same in /Control_Panel/Products/ZWikiWebs?/zwikidotorg/standard_wiki_footer, or install the latest snapshot which you can get over on ZWikiWebs?. That old "write-protected for site robustness" message has been removed also. --SM

No Worries. --Pete


creating new pages from top-level page gives typeerror

Another 0.9.2 problem, this one more of a showstopper. I added a new WikiName, then clicked on the question mark, and got told:

Error Type: TypeError? Error Value: string member test needs char left operand

This is a new one. Peter can you post the traceback ? You can get this by doing "view source" on the error page (or running zope in debug mode). I can't get it myself because I don't have edit permission on your site. --SM

I hasten to add I think this may have something to do with my SiteRoot?/AcessRule?-based vhosting setup, which I'll describe now on the ZWiki PeterMerel page ... anyway ...

Traceback (innermost last):
  File C:\PROGRA~1\GREENC~1\lib\python\ZPublisher\Publish.py, line 223, in publishmodule
  File C:\PROGRA~1\GREENC~1\lib\python\ZPublisher\Publish.py, line 187, in publish
  File C:\PROGRA~1\GREENC~1\lib\python\Zope\__init__.py, line 221, in zpublisher_exception_hook
    (Object: FrontPage)
  File C:\PROGRA~1\GREENC~1\lib\python\ZPublisher\Publish.py, line 171, in publish
  File C:\PROGRA~1\GREENC~1\lib\python\ZPublisher\mapply.py, line 160, in mapply
    (Object: editform)
  File C:\PROGRA~1\GREENC~1\lib\python\ZPublisher\Publish.py, line 112, in call_object
    (Object: editform)
  File C:\PROGRA~1\GREENC~1\lib\python\Products\ZWiki\ZWikiPage.py, line 483, in editform
    (Object: FrontPage)
  File C:\PROGRA~1\GREENC~1\lib\python\OFS\DTMLMethod.py, line 189, in __call__
    (Object: editform)
  File C:\PROGRA~1\GREENC~1\lib\python\DocumentTemplate\DT_String.py, line 538, in __call__
    (Object: editform)
  File C:\PROGRA~1\GREENC~1\lib\python\OFS\DTMLMethod.py, line 182, in __call__
    (Object: standard_wiki_header)
  File C:\PROGRA~1\GREENC~1\lib\python\DocumentTemplate\DT_String.py, line 538, in __call_
    (Object: standard_wiki_header)
  File C:\PROGRA~1\GREENC~1\lib\python\DocumentTemplate\DT_Util.py, line 334, in eval
    (Object: context(REQUEST, enlarge_current=1))
    (Info: REQUEST)
  File <string>, line 0, in ?
  File C:\PROGRA~1\GREENC~1\lib\python\Products\ZWiki\ZWikiPage.py, line 1361, in context
    (Object: FrontPage)
  File C:\PROGRA~1\GREENC~1\lib\python\Products\ZWiki\ZWikiPage.py, line 1583, in present_nesting
  File C:\PROGRA~1\GREENC~1\bin\lib\urllib.py, line 903, in quote
TypeError: (see above)

Naturally I can get rid of the error by hacking the editform so it uses a modified header ... but what does that context(...) thing do anyway?

SM: it's part of KenManheimer's page hierarchy extensions. It displays the indented list of ancestors in the title

This is a peculiar buglet. Do you still see it if you create a brand-new wiki, either basic or zwikidotorg ? In the existing wiki, does it happen all the time ? How are you creating new pages - through the zope management interface ?

JeffGriffith?: The previous bug is occurring with my setup too. I'm getting an identical traceback with ZWiki-0.9.2/Zope2.3.2b1/zwikidotorg. The bug only occurs on the front Page for me. All the child pages work fine.

SM: aha, thanks! I can reproduce it. I believe this should fix it - replace ZWikiPage.py:deepappend with :

    def deepappend(self, nesting, pageid):
        """append a page to the very bottom of a nesting."""
        if type(nesting[-1]) is type([]):
            nesting[-1] = self.deepappend(nesting[-1], pageid)
            return nesting
        else:
            if len(nesting) is 1:
                nesting.append(pageid)
            else:
                nesting[-1] = [nesting[-1],pageid]
            return nesting
(copy the above from source mode)


things missing from zwikiwebs 0.9.2

Another 0.9.2 problem: we seem to have left the manage_change_history_page out of this distribution. Also the advanced editing options don't seem to have made it in ... but don't let all this griping get to you. I'm in love with ZWiki and very happy learning the ins and outs --Pete.

Glad to hear it, thanks for the feedback. manage_change_history_page is part of zope (>=2.2 I think). What problem are you seeing ?

When I click on the date I get:

Traceback (innermost last):
  File C:\PROGRA~1\GREENC~1\lib\python\ZPublisher\Publish.py, line 223, in publishmodule
  File C:\PROGRA~1\GREENC~1\lib\python\ZPublisher\Publish.py, line 187, in publish
  File C:\PROGRA~1\GREENC~1\lib\python\Zope\__init__.py, line 221, in zpublisher_exception_hook
    (Object: ApplicationDefaultPermissions)
  File C:\PROGRA~1\GREENC~1\lib\python\ZPublisher\Publish.py, line 162, in publish
  File C:\PROGRA~1\GREENC~1\lib\python\ZPublisher\BaseRequest.py, line 340, in traverse
  File C:\PROGRA~1\GREENC~1\lib\python\OFS\Application.py, line 245, in __bobo_traverse_
    (Object: ApplicationDefaultPermissions)
  File C:\PROGRA~1\GREENC~1\lib\python\ZPublisher\HTTPResponse.py, line 547, in notFoundError
NotFound: (see above)

Further investigation reveals this is a bad interaction between manage_change_history_page and SiteRoot?. I've overcome this now by adding _SUPPRESS_SITEROOT to the datestamp link. Not pretty, but it seems to work fine.


Advanced edit options should be in there - oh I see.. they didn't make it in. ZWikiWebs? is always lagging, I'll have to work on it later. For now, please append /view_source to grab things of interest from this site, such as UserOptions, editform, & standard_wiki_footer. I think you need to update the first two.

Thanks! --SM

Thank you. All works wonderfully.

zwiki not installable?!? --2003/05/06 09:44 GMT
uh... sorry... but with zope_2.6.2 on my linux-box... i get nearly the same installation problem like others before:

console zope:

2003-05-06T11:38:15 ERROR(200) Zope Could not import Products.ZWiki Traceback (innermost last): File /home/terror/8.raid1.terror/linuxprogs/Zope-2.6.1-linux2-x86/lib/python/OFS/Application.py, line 541, in importproduct File /home/terror/8.raid1.terror/linux_progs/Zope-2.6.1-linux2-x86/lib/python/Products/ZWiki/__init.py, line 12, in ? File /home/terror/8.raid1.terror/linux_progs/Zope-2.6.1-linux2-x86/lib/python/Products/ZWiki/ZWikiPage.py, line 45, in ? File /home/terror/8.raid1.terror/linux_progs/Zope-2.6.1-linux2-x86/lib/python/Products/ZWiki/Regexps.py, line 68, in ? File /var/tmp/python2.1-2.1.3-root/usr/lib/python2.1/locale.py, line 339, in getdefaultlocale File /var/tmp/python2.1-2.1.3-root/usr/lib/python2.1/locale.py, line 272, in _parse_localename ValueError?: unknown locale: de_DE@euro

other modules within zope and plone are working perfect... marc olejak...

zwiki not installable?!? --Simon Michael, 2003/05/06 13:56 GMT

> ValueError?: unknown locale: de_DE@euro

KnownIssues (Python section) has help on this.

subtopics: