Archived GeneralDiscussion.


comments:

History browsing and diff functionality -- Thu, 01 Jul 2004 00:21:28 -0700 reply
Huh. Do you think that the script will suit the Zope thing?

Last Editor Info -- Thu, 01 Jul 2004 07:38:41 -0700 reply
I have just started to try some new stuff with my site and am trying to find out where I can get access to info like that last editor of a page and when it was last updated.

Last Editor Info --DeanG, Thu, 01 Jul 2004 07:49:26 -0700 reply
These names can be gotten from the ZMI manage properties for a page, then integrated into your code.

Check out ZWiki:Rss2/text , http://zwiki.org/Rss2/text for an example of accessing these amidst a dtml search.

..and I'm consistently frustrated that the RSS2 page loads in EPOZ. How can I stop this? (Please, don't edit it.)

0.32rc1 released --simon, Fri, 02 Jul 2004 12:51:42 -0700 reply
Still working on the ReleaseNotes. Thank you for all the patches. I'd love to get some quick sanity checks on this so I can release final in a day or so.

CMFWiki listed in my error log -- Fri, 02 Jul 2004 13:29:22 -0700 reply
I'm still trying to sort out my random Zope failures. Two items that appears frequently in my error log are: ----- PROBLEM(100) ZODB Could not import class CMFWikiPage from module 'Products.CMFWiki.CMFWikiPage?" PROBLEM(100) ZODB Could not import class CMFWikiFolder from module 'Products.CMFWiki.CMFWikiPage?" ----- Why would those items appear in my log? I'm running Plone 2.0.3 and do not have CMFWiki installed anywhere in the system. Does ZWiki rely on some aspect of CMFWiki? When I search for "CMFWiki" in the ZMI, I get no results. Are these errors I can safely ignore?

Thanks!

Scott

CMFWiki listed in my error log --Simon Michael, Sat, 03 Jul 2004 14:53:25 -0700 reply

Does ZWiki rely on some aspect of CMFWiki?
No
When I search for "CMFWiki" in the ZMI, I get no results. Are these errors I can safely ignore?

Yes. I believe these mean you have an old CMFWiki page lingering somewhere in your zodb. Try ZMI find from the root folder. Nice to get rid of, but harmless.

0.32rc3 released, please test --SimonMichael, Sun, 04 Jul 2004 09:25:54 -0700 reply
ReleaseNotes

Thanks -- Mon, 05 Jul 2004 02:44:13 -0700 reply
For the welcome. I have tried Zwiki on GreenCheese? but Pete seems to have some problems there so it will be nice to see it as it is supposed to be! AndrewCates

Thanks --Simon Michael, Mon, 05 Jul 2004 08:25:47 -0700 reply
Yay, greencheese lives! I posted on the system announcement page.

Zwiki 0.32 released --Simon Michael, Mon, 05 Jul 2004 09:05:05 -0700 reply
Zwiki 0.32 (july edition) has been released, a little late due to a client work crunch (and a weekend floating down the Kern river).

Summary: Zwiki's skin is about fully internationalised; translation updates, new polish, dutch & german translations; skin cleanups; pluggable page types; refactoring, bugfixes. ( http://zwiki.org/ReleaseNotes )

This was another month of i18n progress. Both the standard and plone skins, including the standard DTML-based pages if you install those, are now fully internationalised via PlacelessTranslationService? - great work all. Welcome to new translators/developers Marek Ciesielski, Jakub Wisniowski, Jaap Noordzij, Andreas Mayer.

Users won't see much else new since 0.31, just the usual bugfixes. Behind the scenes, there has been another page types refactoring - these are now in separate modules and it's easier to add new ones, see pagetypes/.

Several contributors are successfully using darcs now ( http://zwiki.org/ZwikiDarcs ) and this is helping us to share and integrate patches quicker.

Best wishes, -Simon

About Traditional Chinese with utf-8 coding -- Tue, 06 Jul 2004 05:34:36 -0700 reply
Hi, I test Tradition Chinese with utf-8 (v0.32) and I get error

An error was encountered while publishing this resource.

exceptions.SystemExit?

Sorry, a site error occurred.

Traceback (innermost last):

 Module ZPublisher.Publish, line 180, in publish_module_standard 
Module Products.PlacelessTranslationService.PatchStringIO, line 51, in new_publish 
Module ZPublisher.Publish, line 131, in publish 
Module ZPublisher.Publish, line 101, in publish 
Module ZPublisher.mapply, line 88, in mapply 
Module ZPublisher.Publish, line 39, in call_object 
Module Products.ZWiki.Editing, line 179, in comment 
Module Products.ZWiki.pagetypes.rst, line 34, in preRender 
Module Products.ZWiki.pagetypes.rst, line 26, in renderRstIn 
Module reStructuredText, line 133, in HTML 
Module reStructuredText, line 86, in render 
Module docutils.core, line 438, in publish_parts 
Module docutils.core, line 222, in publish 
SystemExit: 1 

The same error also shows on http://www.zwiki.org/RSTTests

About Traditional Chinese with utf-8 coding --Simon Michael, Tue, 06 Jul 2004 06:48:10 -0700 reply
Sounds like http://zwiki.org/IssueNo0859CommentingOnARSTPageRestartsZope .. perhaps you can add details here. Do you see it only with chinese characters ? I think it has to be considered an RST bug and maybe it needs to be filed in the zope collector.

Re: MONET Axiom front end --Simon Michael, Tue, 06 Jul 2004 14:56:59 -0700 reply
Simon Michael wrote:

Nice! It'll be awesome when they get graphics etc. in there. If I read it right.

It seems like equation anchors and PurpleNumbers should one day play together somehow.

And I missed the wiki again. Now I see why - when a mail is distributed to by the list, rather than the wiki, it does not have the reply_to.

Zwiki / Epoz spell check --Simon Michael, Tue, 06 Jul 2004 16:46:10 -0700 reply

is there a spell check possibility, or can it be programmed into, the Zwiki and WYSIWYG Epoz editor ?

Hi Patrick.. it could be programmed into either. Ward's wiki had a spell check from the beginning (still does), though it gives loads of false misspellings and that extra step after saving was the first thing I wanted to get rid of. I believe Epoz already runs an external html tidy program.

Zwiki editing a database --Simon Michael, Tue, 06 Jul 2004 17:05:13 -0700 reply

Hi, i was wondering if you could edit a page, which instead of being a single document is actually built up of several fields taken from a database. For example I can have a description a country, then a description of the capital, etc etc. Each paragraph if you wish represents a field of a database.

Just a simple matter of programming..

would you be thinking of something like wikipedia's editable sections (ie just editing a part of the page) ?

or more of a general form builder for databases ?

IssueTracker --ArnoPucher, Wed, 07 Jul 2004 01:28:40 -0700 reply
just some thoughts ...

would it be possible to extend the IssueTracker with some new attributes ?

attributes like:

the idea would be to have the chance of a better bug reporting/solving/planning.

AND using the IssueTracker with it's lovely features ... its clear it will never be a bugzilla but some more advanced feature for use in a company would be nice ;)

About Traditional Chinese with utf-8 coding -- Wed, 07 Jul 2004 04:20:10 -0700 reply
No, I also test Englisg ASCII, too. My Chinese site uses UTF-8 character set. I can not get error from error_log under ZMI but show below messages under my Linux console:

 No module named zh
 Exiting due to error.  Use "--traceback" to diagnose.
 Please report errors to <docutils-users@lists.sf.net>.
 Include "--traceback" output, Docutils version (0.3.4),
 Python version (2.3.4), your OS type & version, and the
 command line used.

I use CentOS? v3.1, Zope-2.7.1 and Plone 2.0.3

IssueTracker --DeanG, Wed, 07 Jul 2004 07:23:03 -0700 reply
Are you suggesting these for the Zwiki project, or your own? A few of us have succesfully added fields to our own trackers. The current fields provide similar datatypes to what your suggesting. (I added a "contact", similar in vein to "responsible") Also, we had a featuritus conversation in this topic months ago at ZwikiScrumDiscussion.

If you add graphs/charts to your tracker, please post How-To's, as that would also be a nifty feature, and one often omitted from these products.

Zwiki editing a database --DeanG, Wed, 07 Jul 2004 07:24:37 -0700 reply
abstract thoughts on this at ZwikiRecordBook

skin docs --simon, Wed, 07 Jul 2004 18:29:59 -0700 reply
CustomizingTheSkin has been updated.. improvements welcome.

IssueTracker --ArnoPucher, Wed, 07 Jul 2004 23:52:16 -0700 reply
Primary I asked for my own ;)

I have no idea if this applies to the Zwiki developing process (but it cannot harm to know WHEN a task has been planned ...)

Also I plan (and did already - in alpha) a combination of IssueTracker exporting to an Gantt generator (http://ganttproject.sourceforge.net/). The idea is to collect issues with the tracker, export them to Gantt, plan them there and reimport to ZWiki again.

So you have

The current problem is that for the reimport in ZWiki curretnly I would lose necessary information like duration, planned starting/ending date etc. - so there it is only one way (ZWiki to GANTT) now :(

But I promise to read the ZwikiScrumDiscussion ;)

If I come to a solution I sure add a HowTo ... but don't expect to much - in a few days I am four weeks for vacation in scandinavia ...

About Traditional Chinese with utf-8 coding --Simon Michael, Thu, 08 Jul 2004 08:05:54 -0700 reply

No module named zh Exiting due to error. Use "--traceback" to diagnose.

This may be an RST bug - you may want to file it in the zope collector. You could try to reproduce it in a (non-zwiki) RST Document. And/or, check your locale setting in zope.conf - is it correct ?

IssueTracker --Simon Michael, Thu, 08 Jul 2004 08:24:40 -0700 reply

would it be possible to extend the IssueTracker with some new attributes ?

Hi Arno.. Andreas Mayer (at least) has done this. Check the zwikitracker pages and you'll find it. I think he is currently bringing the patch up to date.

I want this, but I do not want to complicate things for the out-of-the-box tracker user. Also I would love to support this in a general way, so that it's simple for users to add and remove such extra fields.

About Traditional Chinese with utf-8 coding -- Thu, 08 Jul 2004 20:05:17 -0700 reply
Maybe I get the answer (or not)

The No module named zh is the result of no zh.py in lib/python/docutils/languages/. I fix this problem by changing locale as en_US in etc/zope.conf. It's also necessary to set rest-input-encoding and rest-output-encoding as utf-8 cf. http://www.zwiki.org/InternationalCharactersInPageContent

thoughts on discussion --Simon Michael, Thu, 08 Jul 2004 23:41:05 -0700 reply

At the moment: all zwiki discussion is automatically archived on a (hopefully apropos) page on the wiki, and there is perfect equivalence between newsgroup, mail list and wiki. Whichever way you participate the effect is essentially the same. This is unique and in one sense is the simplest arrangement, so I'm reluctant to give it up. Still, is it time to try something new ?

One proposal: we no longer archive all discussion in the wiki. We use the zwiki mail list/newsgroup for discussion like any other project. There will still be a two-way link between list and wiki, but only when subjects have a page name in brackets. ("Not all list mail goes to wiki" on ZwikiAndMailingLists.) Would we still allow subscription to individual pages ? I guess so. But all mail-ins would go to the list.

"Not all list mail goes to wiki" --simon, Thu, 08 Jul 2004 23:56:10 -0700 reply
pro:

con:

Re: thoughts on discussion --Simon Michael, Thu, 08 Jul 2004 23:59:54 -0700 reply

Would we still allow subscription to individual pages ? I guess so.

Or we could not.

two small changes --simon, Fri, 09 Jul 2004 01:20:09 -0700 reply
Mail-outs to individual page subscribers now have zwiki@zwiki.org as the reply-to. Everyone should now use this address.

The zwiki list now forwards non-subscriber mails to me for moderation.

Re: Axiom wiki --Bob McElrath?, Fri, 09 Jul 2004 17:32:41 -0700 reply
root [daly@idsi.net]? wrote:

Bob, =20 Since there hasn't been any discussions of the long term goal of the axiom wiki I guess it's normal to see things move in surprising directions. Here are some of the thoughts that Bill's work inspire. =20 Axiom is based entirely on pamphlet files. Pamphlet files are just standard latex with a couple extras to support "inline" code in the file. They are the basis of the literate programming style in Axiom. So every file in Axiom is a pamphlet. I'm not familiar with the details of "pagetypes" but perhaps a pamphlet pagetype is needed.

A PageType? is a ZWiki construct that encapsulates an input format such as StructuredText, HTML, StructuredText + LaTeX?, etc. See ZWiki/pagetypes.

The format I have been using is StructuredText + LaTeX?. Let me give a little history on this before you all go converting documents en masse... StructuredText (stx) is a big hack of formatting rules piled on top of one another using regexes. It is not well-defined as a structured grammar. (Though I have been working on this) For instance it has no well-defined mechanism to escape markup. If you play with it long enough you WILL run into bugs, particularly when mixing escaping mechanisms (! for stx, \ for latex). It is nice because it ignores HTML markup embedded in stx, so you can mix the two. It is simple enough that anyone can write it, but really, it is a toy. I would not want to base a large project or documentations system around it. Eventually its design limitations will become a hinderance.

reStructuredText (rst) is an attempt to more formally define the grammar. However its rules differ significantly from StructuredText, and it uses the backslash as an escape character, meaning mixing latex with it may be difficult. However as it is a defined grammar one would need to add latex syntax (including math) rules. If someone wants to investigate further this would be interesting.

This leaves pure latex as an input format. Now, clearly, pure latex is an appropriate and powerful input format for documentation. latex2html can already generate html (though it is archaic and equations are poorly aligned -- but we can work on that). There is also the tex4ht variant of latex2html which can output mathml. This is all done using latex commands and style files, and is rather slow. Appropriate web-representation would mean:

1) separate the Big Book into individual pages (chapters?) 2) hyperlinking 3) referencing/footnoting 4) in-page hyperlinking for equations a la existing latexwiki?

So I see a couple options for all this:

1) Use a front-end to convert pamphlet files to a web-appropriate format (stx + latex or rst + latex)

2) Use latex all around, defining a new pagetype. The pagetype does not have to be axiom specific, but it could be.

I think the existing stx+latex can co-exist with a pure latex format. Users can "play" with stx+latex, and more formal documentation can be written in straight latex and placed on the web (but would not be user-editable -- this also alleviates the security concern I mentioned earlier if \write18 is used).

If the Axiom wiki effort can support pamphlet <=3D> webpage translations it would have two benefits. First it would provide an interesting front-end to Axiom, especially with Bill's automation of running Axiom on a wiki web page. This turns out to be nearly as powerful as Mathematica and Maple notebooks. In fact, with some clever web page buttons we could probably reproduce their complete functionality.

Have you looked at Mozilla's XUL?

http://www.xulplanet.com/

Since Mozilla already knows about MathML?, a complete user interface for a computer algebra system could be implemented in a totally platform-independent way inside mozilla, running the axiom process locally or remotely...

If web pages could be converted to, or written originally on the wiki as, pamphlet files then it would be possible to maintain Axiom directly on the wiki which would practically be a research breakthru. It would eliminate the hard-to-use CVS mechanism, enable people to use Axiom directly as a "service" and encourage open math development on the wiki.

Don't underestimate the usefulness of the CVS revision-and-patch mechanism. I've been using darcs lately (better-than-cvs replacement) and it does this very nicely, incorporating things into logical patchsets which can be exchanged. Placing files on the wiki and allowing multiple editors would result in many small edits, and it becomes difficult to track down (and possibly revert) dangerous changes.

Especially with mathematical content, changes should be encapsulated in logical units, carefully reviewed by experts, and run through numerous test cases to ensure mathematical correctness.

I've been struggling with the issue of how to develop a browsing=20 structure for Axiom's pamphlet and this wiki has great potential to solve that problem in a truly novel way.

It also gets indexed by google.

Axiom uses a fairly limited range of Latex mostly because my Latex talents are limited. Support for the \begin{array} environment or the \begin{thebibliography} environment are about the most difficult=20 of the parts of the Latex used. (Actually, if the \bibitems in a=20 bibliography were automatically turned into hyperlinks that would be sweet).

This is something that has been on my TODO list for LatexWiki for a while.

IssueTracker -- Fri, 09 Jul 2004 23:02:35 -0700 reply
Hi Simon,

Hi Arno.. Andreas Mayer (at least) has done this. Check the zwikitracker pages and you'll find it. I think he is currently bringing the patch up to date.

Hmm ... I searched (the wiki and in the IssueTracker) but I couldn't find anything about this - just some old proposals to add a version/assigned-to field ...

Maybe you could point out the page ?

Thanks in advance, ArnoPucher

IssueTracker --simon, Sat, 10 Jul 2004 20:00:49 -0700 reply
IssueTrackerOwnerAndDueDate

zwiki/zopewiki.org catalog updates, breakage --Simon Michael, Sun, 11 Jul 2004 10:38:04 -0700 reply
Heads up - I have been battling with the zwiki.org and zopewiki.org catalogs.

The Title and text indexes in both are now utf-8 aware, so you can search for utf-8 characters.

But, a number of site functions are giving catalog errors. I have to leave it alone for the moment.

plone howto wiki --Simon Michael, Mon, 12 Jul 2004 21:39:32 -0700 reply
I forget that the plone howto section is probably one of the most active zwikis out there right now, if you measure by number of editors. Check it out.

http://plone.org/documentation/howto/FrontPage/recentchanges?period=Week&summaries=on

ZWikiRegulations error -- Tue, 13 Jul 2004 11:05:41 -0700 reply
I'm getting the following event.log entry after installing ZWiki-0.32.0 (Zope 2.7.1, python 2.3.3, win32-XP):

 ------
  2004-07-13T13:28:37 INFO(0) Zope Ready to handle requests
  ------
  2004-07-13T13:46:54 PROBLEM(100) ZODB Could not import class ZWikiRegulations from   module Products.ZWiki.Regulations
 ------
 2004-07-13T13:46:58 INFO(0) ApplicationManager Shutdown requested by "admin"
------
 2004-07-13T13:46:58 INFO(0) ZServer closing HTTP to new connections
------
 2004-07-13T13:46:58 INFO(0) ZServer closing FTP to new connections
------
 2004-07-13T13:46:58 INFO(0) Zope Shutting down with exit code 0'

Any pointers?

ZWikiRegulations error --Simon Michael, Tue, 13 Jul 2004 11:13:06 -0700 reply

2004-07-13T13:46:54 PROBLEM(100) ZODB Could not import class ZWikiRegulations from module Products.ZWiki.Regulations

I get that too.. it's harmless. I assumed it's due to an old CMFWiki page left somewhere in the zodb. Brownie points to whoever can solve it.

ZWikiRegulations error -- Tue, 13 Jul 2004 11:21:49 -0700 reply
Maybe harmless, except Zope is not starting:-) I had to reinstall my previous ZWiki version in order to access the ZMI.

ZWikiRegulations error --Simon Michael, Tue, 13 Jul 2004 11:32:10 -0700 reply
Eh ? That shutdown always happens ??

I don't believe it's related to the ZwikiRegulations? message, though.

ZWikiRegulations error --Simon Michael, Tue, 13 Jul 2004 11:33:06 -0700 reply
But downgrading Zwiki fixed it ? Well then I'm at a loss for words.. we could debug it on #zwiki.

confluence --Simon Michael, Tue, 13 Jul 2004 11:43:07 -0700 reply
An interesting integrated presentation of a wiki farm:

http://wiki.osuosl.org/dashboard.action

ZWikiRegulations error -- Tue, 13 Jul 2004 11:52:45 -0700 reply
I rollbacked and redeployed twice actually as I thought I was dreaming... Guess I'll have to look under the hood a bit more... This is Win32, so maybe I just need to reboot:-) Keep you posted.

problem with using italics? -- Tue, 13 Jul 2004 13:59:57 -0700 reply
(Disclaimer: I'm using my old fork of zwiki, so it's possible things have changed...)

In my ongoing stability annoyances, I find that a page edit is highly likely to generate a zope crash if it includes a chunk of text surrounded by * (for italics - we're talking StructuredText). If I remove the * marks the page saves fine. And these are not large pages, these are my short blog-like pages. Does this mean anything to anyone? (e.g. was there a memory leak that's been fixed, etc.) --BillSeitz

problem with using italics? --DeanG, Tue, 13 Jul 2004 14:09:42 -0700 reply
Is it the same with a page similarly peppered with HTML?

problem with using italics? --Bob McElrath?, Tue, 13 Jul 2004 14:23:40 -0700 reply
Can you send an example page? (or give a url for one)

problem with using italics? --simon, Tue, 13 Jul 2004 17:01:23 -0700 reply
Bill - a zope crash ? This almost certainly can only be the old favourite IssueNo0226? on freebsd. Certain unlucky configurations of text can make the regexps work harder causing the python stack size to be exceeded. My guess would be you need to increase yours to 1Mb.

problem with using italics? -- Wed, 14 Jul 2004 06:51:04 -0700 reply
I dealt with that issue a long time ago, though I'm not sure it ever really went away. But it seems like it's gotten worse recently. And here's a sample page, which is quite short and simple. Pretty much the entire paragraph after the first sentence should be in italics. Even now, when the process had just been restarted, trying to save that edit to the page gives me the proxy error. http://webseitz.fluxent.com/wiki/z2004-07-12-KunstlerOnMoore

ZWikiRegulations error -- Wed, 14 Jul 2004 11:29:36 -0700 reply
Now fixed. I had stored a backup copy of the previous ZWiki version in the Zope Products directory instead of moving it to some other place... wizard that I am!

problem with using italics? --SimonMichael, Wed, 14 Jul 2004 13:25:17 -0700 reply
Perhaps a python upgrade overwrote your patched python ? That happened to me. And make sure your stack is 1Mb, not less as some recommend. Look in event log for the error messages characteristic of this issue. Do you see them ?

If you see that python is dying silently with no error message at all, on the other hand, I would suspect something newer: IssueNo0860? .

mail fix --simon, Wed, 14 Jul 2004 21:49:21 -0700 reply
I broke mail-out to the list today - it should be fixed now.

The reason was I am tuning the list options to minimize spam moderate requests and mailserver replies. It seems the list gets about 100 spam per day.

Re: mail fix --Simon Michael, Thu, 15 Jul 2004 10:16:59 -0700 reply
simon wrote:

I broke mail-out to the list today - it should be fixed now.

Still working on this.. the mailout code has been refactored, should be stabilised shortly.

Anonymous subscription --Jaap Noordzij, Thu, 15 Jul 2004 10:34:08 -0700 reply
I noticed that in all my Plone Zwiki's the "subscribe" tab shows, even when the user never logged in to the site. Clicking the tab and the button results in "Anonymous User" added to the subscription list. Imho you should prevent the tab when a user is nog logged in to the site. I changed this in the Portaltype - Wiki Actions with the condition :

  python: member and object.isMailoutEnabled()

I think this in CMFInit?.py

away from keyboard --simon, Fri, 16 Jul 2004 10:02:26 -0700 reply
Hi all: I'll be offline during the next week..

Restrict Access to zwiki/zope to host box -- Wed, 21 Jul 2004 12:47:21 -0700 reply
How do I configure a zwiki implementation running on a Windows XP box so that it only allows access from that same box?

Thanks in advance, W.L.

Restrict Access to zwiki/zope to host box --Racing Pitoune, Thu, 22 Jul 2004 16:33:23 -0700 reply
As easy as pie: just cut the network cable! ... (only kidding:-). I'd say this is a Zope issue and there probably is a whole spectrum of ports that could be used as a port-base directive in zope.conf (I never tried this.). Have you considered applying security over your ZWiki folder contents? I have a restricted folder somewhere with ZWiki pages in it, and they look pretty secure (for what it's worth:-).

Restrict Access to zwiki/zope to host box -- Thu, 22 Jul 2004 17:37:14 -0700 reply
Thanks for the response.

I will do some searches on zope.conf for a solution. I haven't done a lot with the security over folders features because the zwiki in question is not being used for collaboration between multiple users but instead is a single user repository for organising information. It would be better if I could configure the zwiki/zope/zserver to not interact with any other machines on the internal network at all. (a network firewall keeps outside users at bay).

Thanks again,
W.L.

Restrict Access to zwiki/zope to host box --Racing Pitoune, Thu, 22 Jul 2004 19:51:32 -0700 reply
"Not being used for collaboration", that's exactly the point. I'd assign all ZWiki permissions to Owner for that sensitive folder, then any figment of collaboration would buzz instantly off:-) And Access contents information looks promising as well.

Problem with changing ZWikiPage-Permissions -- Wed, 28 Jul 2004 02:39:13 -0700 reply
I installed Zope 2.7.1 and ZWiki-0.32. Whenever I try to change any permission on any ZwikiPage?, I get the error "Some permissions had errors: View". Am I doing something wrong? On http://old.dzug.org/SchreibMit/ZopeFaq/Entwicklung/permission_error they say that this error occurs, when a Permission string is used to protect a method while this Permission String has not been assigned to the Admin role. Could this have happened in ZWiki? Although an error page is generated, it seems like the permissions are changed just the same.

Problem with changing ZWikiPage-Permissions --Racing Pitoune, Wed, 28 Jul 2004 18:53:42 -0700 reply
I've never run across that one and I change permissions routinely just about everywhere from my root folder down. How about permissions on non-ZWiki files elsewhere in the ZMI? Did you tweak acquired permissions before installing ZWiki? Is Zope 2004-07-14 hotfix installed? This hotfix seems to conflict with ZWiki 0.32 in some cases. What platform are we speaking of? Maybe installing Zope 2.7.2 would provide a workaround.

Problem with changing ZWikiPage-Permissions -- Thu, 29 Jul 2004 03:02:03 -0700 reply
Good to know that it is only a local problem, I will try reinstalling. Permissions of all other Zope products can be changed without problems. Zope 2004-07-14 hotfix has not been installed. Platform is Suse-Linux 9.1. I haven't changed acquired permissions as far as I remember. Since the permissions are changed all the same, the problem for me is not really serious. I'll try Zope 2.7.2 as well. Thanks for the advice!!

Make Zwiki appear in my language? -- Thu, 29 Jul 2004 16:30:16 -0700 reply
I'd like to make my Zwiki appear in my language - better even: The language the Browser sends. I've noticed there's a i18n folder in the Repository; but how do I set it up? Thanks for any hints.

Make Zwiki appear in my language? --Racing Pitoune, Thu, 29 Jul 2004 20:20:17 -0700 reply
Grab the latest ZWiki, install Placeless, compile .po files into .mo files (as described in the install procedure), select the required language settings in your browser, and you'll end up with a localized ZWiki interface (many languages are still missing at this point, though).

Zwiki - my language works - BUT character encoding does not -- Fri, 30 Jul 2004 05:01:03 -0700 reply
I just installed the placelestranslationservice it worked without doing anything else (just install). The thing is, that zope ( 2.6.4 ) doesn't seem to send back character encoding to be UTF-8 allthough it is correctly incorporated in wikipage_macros:

<html i18n:domain="zwiki"> <head metal:define-macro="head" tal:define="dummy python: request.RESPONSE.setHeader(Content-Type,text/html;; charset=UTF-8); "> <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">

Do I have to adjust anything else to be able to see for example umlauts correctly?

Zwiki - my language works - BUT character encoding does not -- Fri, 30 Jul 2004 11:15:25 -0700 reply
It worked for me to change the encoding and decoding of restructured text documents in etc/zope.conf to utf-8. Just add the following two lindes: "rest-input-encoding utf-8", "rest-output-encoding utf-8". Benedikt

20040818 response moved to GeneralDiscussion