Archived GeneralDiscussion.


comments:

Oops -- Mon, 01 Aug 2005 15:29:47 -0700 reply
I'm sorry, but the lptitle.jpg file is mine -- I meant to put it on my ZWiki, but I had both wikis open in tabs. I don't know how to remove an image, though, or if it's possible w/o being the site owner. How embarrassing. :-/

Oops --Simon Michael, Mon, 01 Aug 2005 16:11:55 -0700 reply
anonymous wrote:

I'm sorry, but the lptitle.jpg file is mine -- I meant to put it on my ZWiki, but I had both wikis open in tabs. I don't know how to remove an image, though, or if it's possible w/o being the site owner.

It's not.. no worries, I've removed it.

Too many links slow down web page -- Wed, 03 Aug 2005 00:37:30 -0700 reply
Hi, I'am building some kind of dictionary with ZWiki. I have one hand made page where I collect all entries. As soon as I have finshed a entry I want to delete it from this page. However, accessing this page from a browser takes really a long time. Any idea how I could speed it up ? Thanks sigbert

Zwiki skin -- Thu, 04 Aug 2005 09:45:38 -0700 reply
Hello, I'm new to zwiki, I've installed it on a free zope account at objectis.net one week ago. Since this install, I'm trying to change the skin (remove the "comment" thing, the "minimal..."). I downloaded the zwiki standard skin, changed wikipage.pt, created a file called "wikipage" in the ZMI and uploaded my changed wikipaged.pt in it. I thing it is what I should do, actually, that's what I understood from the help ;)

But, it doesn't work, nothing change at all ! So, now, I'm posting here, I've read all the doc but I don't know what to do.

Thank you

PS : I'm sorry for my bad english grammar.

list posts not going to GeneralDiscussion --Simon Michael, Thu, 04 Aug 2005 12:45:13 -0700 reply
Simon Michael wrote:

(third attempt at mailing this.. 1st appeared nowhere, 2nd appeared on list only..)

No, my mistake. All three posts appeared on the list. All had GeneralDiscussion in the subject so should have appeared on that page; none of them did.

I believe this is because the wiki got unsubscribed from the list back in april. I've resubscribed the wiki[1]? to the list, let's see if this post makes it through to the wiki.

[1]?.. actually just the GeneralDiscussion page as per http://zwiki.org/ZwikiDotOrgDiscussionTests

wikimail fixed, reply --Simon Michael, Thu, 04 Aug 2005 12:50:09 -0700 reply
List traffic intended to cc GeneralDiscussion seems to be flowing to the page again, and sigbert will at last see my reply.

Simon Michael wrote:

Hi sigbert.. want to post your code here ? Be sure to use structured text literal quoting, ie indented after a paragraph ending in :: . Or, set it up as a demo page here.

gmane puzzle --Simon Michael, Thu, 04 Aug 2005 12:57:46 -0700 reply
Only one puzzle remains for the moment..

Accessing gmane via NNTP you can see all the messages in this thread. But the web interface at http://news.gmane.org/gmane.comp.web.zope.zwiki shows only the first message (3 Aug 09:37 anonymous GeneralDiscussion Too many links...).

Click on the message and then its subject, and you do see the whole thread, but displayed as part of the gmane.comp.web.zope.zwiki.edits newsgroup (the zwiki-edits list).

I don't know why this is. Gmane tries to hide cross-posts, I guess.

Too many links slow down web page II -- Fri, 05 Aug 2005 00:16:56 -0700 reply
Hi, basically I use in the code [Entry text]? . Approx. 100 entries, see http://141.20.130.71:8080/slides/StatWiki/ToDo. Sigbert

Too many links slow down web page II --Simon Michael, Sat, 06 Aug 2005 08:03:19 -0700 reply
That's a scenario where unfortunately we perform badly. Cf http://zwiki.org/818PagesWithManyFreeformLinksRenderSlowly

I'm not sure what to suggest, other than

character encoding --Simon Michael, Sat, 06 Aug 2005 08:07:03 -0700 reply
PS I see your pages have some iso8859-1 encoded characters, instead of the utf-8 zwiki expects - perhaps you need http://zwiki.org/944NeedAnAutomaticMethodToConvertFromOldEncodingIso88591ToUTF8 ?

Too many links slow down web page II --Simon Michael, Sat, 06 Aug 2005 08:10:13 -0700 reply
Oh, and try setting up a catalog - http://zwiki.org/Configuring#catalog

character encoding -- Mon, 08 Aug 2005 05:07:52 -0700 reply
Hi, i did so, but now I have to revisit all my pages to correct the german umlaute. And I still cannot have them in the page titles... Sigbert

Zwiki linked -- Tue, 09 Aug 2005 17:21:36 -0700 reply
"How To Use Wikis for Business" , InformationWeek?

http://informationweek.com/shared/printableArticle.jhtml?articleID=167600331

Zwiki linked --Simon Michael, Tue, 09 Aug 2005 17:53:18 -0700 reply
Nice!

And another general one here:

http://www.informationweek.com/blog/main/archives/2005/08/poll_whats_a_wi.html

... --Simon Michael, Wed, 10 Aug 2005 05:33:05 -0700 reply
oops.. this didn't go out due to a system reinstall.

-------- Original Message -------- Subject: Re: subtopic page order Date: Sat, 06 Aug 2005 14:35:17 -0700 From: Simon Michael <simon@joyful.com> To: zwiki@zwiki.org References: <op.su3uqgy0jvf8eq@hp27551879432.hsd1.wa.comcast.net>

Glad to hear it Tom. I know sooner or later it's going to annoy you, but so far so good! :)

- IS there a way, currently, to get manual control over child page order display in subtopics?

Yes - click the title of the parent page and use the ^ buttons. Primitive, but it works. Would you mind checking/clarifying the reordering paragraph at http://zwiki.org/PageHierarchy ?

Also note the ordering will be lost if you delete the outline object in the ZMI, or if you regenerate it with /updatecontents. That's probably not for the user's guide though.

- Is there a problem relating to the AT issue, in Plone 2.1?

Yes, I think you mean http://zwiki.org/1137 . Workaround but no fix.

zope upgrade time! --Simon Michael, Thu, 11 Aug 2005 08:50:06 -0700 reply
I will upgrade the server to 2.8.1 today.

Re: parsing inconsistency --Simon Michael, Fri, 12 Aug 2005 14:57:36 -0700 reply
Hi Tom. Old version of zwiki ? At http://zwiki.org/RSTTests [] is not linked in either case.

Unable to update ZWiki's Pot file --Jens Nachtigall, Fri, 12 Aug 2005 15:43:48 -0700 reply
Hi,

I'd like to update the german translation. Beforehand I'd like to follow http://zwiki.org/HowToUpdateZwikiPotFile

However, I had a problem following this "howto". Here is why: http://zwiki.org/HowToUpdateZwikiPotFile#msg20050811071559-0700@zwiki.org

I did not get an answer to this comment yet
I always thought wiki comments would be forwarded to this mailing list. However, I did not see this one posted here (so i am resending it now) -- am I mistaken about the forwarding?

Any ideas on why I cannot apply the patches?

regards, jens

Re: Unable to update ZWiki's Pot file --Jens Nachtigall, Sat, 13 Aug 2005 02:34:58 -0700 reply
Hi Simon,

I saw your comment there, in fact, but haven't looked into it. Perhaps the zope 3 source layout has changed ? Maybe you can search for those files and edit the paths in the patch file(s) so they work again.

I already did that, but the patch is rejected. Which version of Zope3 did you use? I think the easiest would be if I took the same version. I don't want to fiddle around with the zope3 sources too much.

TIA,

Jens

Re: Unable to update ZWiki's Pot file --Simon Michael, Sat, 13 Aug 2005 03:08:43 -0700 reply
It was the X3.0 release I think.

wiki cleanup --Simon Michael, Sat, 13 Aug 2005 10:03:05 -0700 reply
Hi all,

With the server upgraded to zope 2.8.1 (plone.zwiki.org upgrade still in progress, see issue tracker) I want to get some WikiCleanup done.

In particular, I will review and fix the page hierarchy and page ordering which was messed up during recent activities. If possible I'll record it somehow in case it needs to be recovered again.

Also, I have been thinking of archiving or de-emphasizing a portion of zwiki.org content, so that's it clearer which is current maintained documentation and which isn't. I think documentation is like code to some extent: there's no point having more of it than you can maintain and keep clean. Zwiki has had a great deal of documentation written down over the years, but I suspect that many visitors find the docs very unclear.

So, any ideas or volunteers to help ? I am considering options such as: keeping unmaintained pages in a separate branch in the hierarchy; not linking them on the front page; displaying them with a different style, eg gray background; moving them to a separate wiki or /archive/ subfolder (possible feature here ? change delete button to archive and use the recycle_bin?); listing them in a big table, reviewing and deleting them ?

new wikibadge proposal for your consideration --Simon Michael, Sat, 13 Aug 2005 14:19:36 -0700 reply
http://zwiki.org/PageReviewer **

Re: Unable to update ZWiki's Pot file --Jens Nachtigall, Sun, 14 Aug 2005 12:35:40 -0700 reply

It was the X3.0 release I think.

Hhm, I tried that one (ZopeX3?-3.0.0 final) as well as ZopeX3?-3.0.0a1 and ZopeX3?-3.0.1. No success. Not only the dir order changed, also within the files that need to be patched there is a big difference, that is, it is not obvious what needs to be changed.

I'd like to ask you if you should not run "make pot" and commit it
so that I could step up to the thing I actually really wanted to do: translating them :)

Jens

download copy of Zwiki -- Mon, 15 Aug 2005 00:34:26 -0700 reply
Hi, I would like to give the user of my ZWiki to download the contents of the wiki. Is there any tool available ? I tried to use "wget", but I always stay in "minimal" mode, which does not show the page hierarchy and I found no way in wikipage.pt to change this behaviour. If I tweak the macros then I guess this changes the behaviour of all wiki's on the Zope server. Thanks in advance Sigbert

LatexWiki.tar

Fixed LatexWiki -- Mon, 15 Aug 2005 03:29:18 -0700 reply
I fixed (well, sort of) LatexWiki in order to get it working with python 2.4, I didn't know where to put it, so I put it here. I don't know, axiom is working.

Fixed LatexWiki -- Mon, 15 Aug 2005 03:31:15 -0700 reply
At least Latex is working.

test -- Mon, 15 Aug 2005 04:36:31 -0700 reply
\begin{equation} \alpha=\frac{\beta}{\Gamma} \end{equation}

Re: link to file systems - a no-go --Simon Michael, Tue, 16 Aug 2005 11:45:20 -0700 reply
Hi Tom,

Is there something going on behind the scenes here - some kind of hidden lookup table being created? I can't image how else this link could be made to work, unless I'm overlooking something really obvious.

I'm not familiar enough with RST to say. I think it has some way to write html and say "don't touch that". I expect it works in a stx or html page ?

I sometimes use a LocalFS object to make for easier urls to files, but I don't think that's your need here.

Re: ZWiki linking persistence in HTML ??? --Simon Michael, Tue, 16 Aug 2005 11:47:27 -0700 reply

Primary notes: `"C:\Documents and Settings\Tom C\My Documents\_tasks\_task [t070f] PostgreSQL.doc"`

Note the "!" I have to place in this string to keep the HTML (!) parser from trying to make a wiki link out of what follows. Very surprising...unless I'm missing something, again.

That seems normal to me (you can also put the ! at the start of the line). Zwiki sees that as a wikiname, since it's not inside a html tag or other special construct. Note wiki linking is done even in html wiki pages, unless you turn it off as in http://zwiki.org/Configuring .

Zwiki error on plone 2.1 rc1 -- Wed, 17 Aug 2005 10:01:21 -0700 reply
In Plone 2.1 rc1, Zope 2.7.7, when I add a Zwiki (0.44.0) page, I obtain an attribute error: None Type object has not attribute getPhysicalPath (I don't know if this is the right place for this question, so I don't insert the traceback). Is this a known problem? Thanks.

Zwiki error on plone 2.1 rc1 -- Wed, 17 Aug 2005 12:54:19 -0700 reply
For more precision, I have this problem in an ATfolder?, Everything seems work in a normal zope folder added to the Plone site in ZMI. Thanks again, Michele.

Zwiki error on plone 2.1 rc1 --Simon Michael, Wed, 17 Aug 2005 13:22:33 -0700 reply
I don't know of this one.. it's ok to post tracebacks here, but IssueTracker will be even better, I think this deserves an issue page.

Thanks -Simon

zwiki.org mail setup --Simon Michael, Wed, 17 Aug 2005 14:14:07 -0700 reply
As you may know, zwiki.org has mailing list(s) and wiki integrated in interesting ways. Over the years I have stepped through various configurations in the interests of science, but the goal is effectiveness and usability for we the zwiki community. It's time for my periodic review of the setup and solicitation of ideas...

Current status is described by a detailed list of tests linked off the FrontPage -> discussion box -> AboutZwikiDiscussion -> ... . From memory:

  1. all wiki edits are mailed out to page subscribers and to the zwiki-edits mail list (and gmane.comp.web.zope.zwiki.edits newsgroup), which may be used to read all traffic, or send mail in to any page
  2. GeneralDiscussion page edits are mailed out to that page's subscribers and to the zwiki mail list (and gmane.comp.web.zope.zwiki newsgroup), which may be used to send mail in to GeneralDiscussion only, and may also be used for off-wiki discussion (by omitting the page name from the subject)
  3. the bugs at zwiki.org mail-in address creates new issues

Still too complicated. Too much thinking required about where to subscribe, where to send, what to do with the subject, who will see it, where to reply. Point 2 in particular. In part, traffic has subsided again and the need for simplicity now outweighs the need to segment newcomer and developer discussion. (That could change again.)

Enhancing Zwiki so that it can send edits to some and comments to other subscribers, would open up new possibilities. Other than that, how can we make things better ?

I think I will drop the off-wiki/on-wiki capability of the zwiki list; I'll make it and GeneralDiscussion mirror all of each other's traffic regardless of subject. Then we will have zwiki-edits list = whole wiki and zwiki list = GeneralDiscussion. This is a permutation we haven't tried.

Maybe GeneralDiscussion should be renamed back to GeneralDiscussion or just Discussion.

Other ideas ?

zwiki.org mail setup --simon, Wed, 17 Aug 2005 14:43:20 -0700 reply
Later, perhaps:

corresponding to the different needs of newcomer, the developer/power-user, and the wiki gardener ?

Printing issuetracker issues -- Thu, 18 Aug 2005 11:39:30 -0700 reply
I'm looking for a way to (display and) print all issues (with status, description, comments and all) in an issuetracker. As I was taught not to write any program that already has been written by someone else, I'm asking it first: did someone by any chance already find a way to do this?

About "add news item" tab -- Wed, 24 Aug 2005 04:32:18 -0700 reply
Using zwiki in plone, is it possible to hide the tab "add news item" and permit to anonymous user modify and add new pages via "wiki links"? And why this tab is not "editable" in portal_types ->zwiki->actions? Thanks Michele

Re: Cannot grant Members page creation rights in Plone/ZWiki --Simon Michael, Thu, 25 Aug 2005 08:11:47 -0700 reply
Hi Tom. I assume you've stared at the permissions notes on QuickReference. It sounds like your user has insufficient permission simply to view the wiki page ? That usually means they are lacking one of View and Access contents information permissions.

Tip: when experimenting with permissions you might want to uncheck the acquire box and set the permissions explicitly. Eg on the wiki page in question. Otherwise you aren't sure what you might be acquiring from above.

thanks --Simon Michael, Sun, 28 Aug 2005 18:31:35 -0700 reply
cc'ing this to GeneralDiscussion:

simon wrote:

..for the feedback. I'm leaning towards dropping this, for now, as I don't think it carries it's weight, especially on zopewiki. I think it's a good direction to explore, but I haven't had time to make it fast and monitor for problems. -- forwarded from http://zwiki.org/WikiLine#msg20050828181623-0700@zwiki.org

iungo --simon, Sun, 28 Aug 2005 21:26:19 -0700 reply
iungo is very interesting, check it out: http://www.iungo.org

wiki links in Plone -- Mon, 29 Aug 2005 13:56:34 -0700 reply
Hi, First of all, excuse my bad English. Second, I hope my questions are not too trivial for you! In my Plone Intranet a user of mine wants the links between his wiki pages appear different from the other "classic" Plone links. So I have modified the renderLink method at rows 587,606,637 adding a class="wikilink" to the returned links; that is from: return '... to return ...'.

So now I can control these links in plonecustom.css in the folder with the Zwikipages. and it seems work. But my question is: is there a more correct way to obtain this? Thanks, Michele

wiki links in Plone --Simon Michael, Mon, 29 Aug 2005 15:14:03 -0700 reply
Hi.. I think that is the best way to do it.

About "add news item" tab --Simon Michael, Mon, 29 Aug 2005 15:18:49 -0700 reply
anonimo wrote:

Using zwiki in plone, is it possible to hide the tab "add news item" and permit to anonymous user modify and add new pages via "wiki links"? And why this tab is not "editable" in portal_types ->zwiki->actions?

Assuming you mean the "add new item" menu.. I have often had the same desire and found it difficult to do without customizing plone's core templates. If you study those templates you'll see, I think the short answer is that "add new item" is displayed based on permissions rather than being a simple action that's easy to hide. It's a problem for wikis in plone because it leads into confusing issues when people use the plone ui in a wiki.

uploaded files list ? --Simon Michael, Tue, 30 Aug 2005 09:02:05 -0700 reply
Isn't there a list of uploaded files in zwiki.org .. can anyone remember where ?

blog update --Simon Michael, Tue, 30 Aug 2005 09:13:43 -0700 reply
HI folks.. FYI, I am posting the occasional update at http://joyfulsystems.blogspot.com , also.

About "add news item" tab -- Tue, 30 Aug 2005 09:39:56 -0700 reply
http://plone.org/documentation/how-to/restrict-addable-types describes how to tell Plone which types are allowed in a folder. I tried to implement this in a ZWiki environment, with some sort of success.

According to the howto, you have to customize getAllowedTypes.py and set the new only_addable_types property of the containing to the types you want. If you leave the property value blank, you won't be able to add any pages through Plone. A manager can still add documents through the ZMI. However, ZWiki pages don't inherit this property. If you set it directly on a wiki page, the add new item menu disappears, while the wikilinks mechanism still works. The new page however again lacks the property, and the menu is being displayed... Perhaps someone has a quick fix for this.

About "add news item" tab --Simon Michael, Tue, 30 Aug 2005 10:11:55 -0700 reply
Interesting.. what if you put the property on the folder ?

About "add news item" tab -- Tue, 30 Aug 2005 11:15:09 -0700 reply
I have modified "global_contentmenu" template (the Plone list helped me to find it!) adding a span tag with a tal:condition in this way (Google helped me!):

  <span tal:condition="python:user.getUserName()!= 'Anonymous User'">
    <li>
        <div class="menuPosition">
            <a href="#"
               title="Add new items to this folder"
               onclick="return buttonClick(event, 'objectMenu');"
               onmouseover="buttonMouseover(event, 'objectMenu');"
               i18n:attributes="title">
               <span i18n:translate="label_add_new_item">Add New Item</span></a>
               ...............................................................
               </a>
                </li>
                </metal:block>
            </ul>
        </div>
    </li>
  </span> 

It seems work. But I'm not sure it is a correct way, I have not tested it well. Michele

About "add news item" tab -- Tue, 30 Aug 2005 14:18:35 -0700 reply
I tried to put it on the folder first but that didn't work... I did expect it to work though, it just didn't so I tried to set the page property instead to see if it would work at all.

list missing entries --JózsefJároli, Wed, 31 Aug 2005 03:58:44 -0700 reply
Does anybody know/Is there a way to list referenced, but missing pages? (I am looking for a list of the links with the question mark at the end :) Thanks, József

list missing entries --Simon Michael, Wed, 31 Aug 2005 08:40:50 -0700 reply
There's no built-in way that I can think of. I know this is something people want to do.

There is a method links() which lists all wiki, interwiki, and url links in a page. I believe it's in the catalog metadata. So I guess you could query this for all pages, do a union, and discard the non-wikilinks.