Submitted by : koyoshi at: 2010-01-12T02:50:27-08:00 (11 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

I was installing Zwiki2.0b1 with Zope-2.12.2 and import my own zwiki site.I almost have not any problems.

Today, I tried to view my issuetracker and that pages. My zwiki shows blank page without any error messages.

I thought probably ir is one of non-ascii characters issues on ZWiki-2.12.2. Then I remove all non-ascii characters catrvoriesin the issue_categories property to find what it do. My zwiki shows the issuetracker and all issue pages complately.


CPU:Pentium4 2GHz (single core, non multi thread)
Zope:2.12.2 (<- 2.12.1)

Zope setup:

locale        :ja_JP.UTF-8 in my zope.conf
 utf-8 on my ZMI's root folder property tag

Zwiki usage:


... --simon, Tue, 12 Jan 2010 10:14:39 -0800 reply

Thanks for the report. Can you send me the url of your issue tracker if it is accessible ? Can you see any error in Zope's error_log, or in event.log (you may need to increase logging verbosity to BLATHER).

I'm sorry. It's my misstake --koyoshi, Sat, 16 Jan 2010 00:29:12 -0800 reply

Thank you for your advice, and I'm sorry for my wrong report.

This isuue was occurred without a file needed for stabilization of using unicode characters.

The file is


import sys

This file must be into the site-packages folder,

if we tried to see the objects titled into non-ascii characters on the more older zope ZMI.

Last year, I installed this file for my Zope2.12.1.

But, I thought that I wanted to do it more easy and automatical steps.

Recently, I tried to make scripts for the current zope's installing and setup. I was using the scripts to install a lot of times for that test. Now, one of these Installed Zope2.12.2 Instance and it's python's environment.

Actually, I wasn't aware that it had not

I'm sorry for my mistakes. m(_ _)m And thanks for your help.

To halt this mistake, My scripts were fixed for install of current zope.

I posted this script file in my blog with my broken English. ^^;;


Name: '#1464 Can not display issuetracker with Zope-2.12.2 and non-ascii issue_categories' => '#1464 Without, not display issuetracker with Zope-2.12.2 and non-ascii issue_categories' Severity: serious => minor Status: open => closed