Edit detail for #478 0.17.0rc1 appears broken... revision 1 of 1

1
Editor: LarryP
Time: 2003/03/26 19:51:29 GMT+0
Note:

changed:
-
I've just tried installing 0.17.0rc1, as well as the very latest from CVS with the same result (product is broken in ZMI Control Panel) ---

Traceback (innermost last):
<pre>
  File /home/zope/lib/python/App/RefreshFuncs.py, line 182, in performSafeRefresh
  File /home/zope/lib/python/App/RefreshFuncs.py, line 169, in performRefresh
  File /home/zope/lib/python/OFS/Application.py, line 772, in reimport_product
  File /home/zope/lib/python/OFS/Application.py, line 541, in import_product
  File /home/zope/lib/python/Products/newZWiki/__init__.py, line 12, in ?
  File /home/zope/lib/python/Products/newZWiki/ZWikiPage.py, line 61, in ?
  File /home/zope/lib/python/Products/newZWiki/Fit.py, line 131, in ?
  File /home/zope/lib/python/Products/newZWiki/Fit.py, line 132, in FitSupport
  NameError: name 'security' is not defined
</pre>
I'm running Zope 2.6.1 on RH Linux 7.2

I've been using ZWiki (earlier versions) for months now with no problem, so I suspect there's some minor bug in the latest release.


<b>good catch!</b> --SimonMichael, 2003/03/26 19:46 GMT<br>
I believe this will fix Fit.py ::

 except ImportError:
    class FitSupport:
        security = ClassSecurityInfo() # add this

Thanks.

<b></b>LarryP, 2003/03/26 19:51 GMT<br>
That did it!  Thanks for the quick fix...  

Submitted by : simon at: 2003-10-26T21:31:52+00:00 (17 years ago)
Name :
Category : Severity : Status :
Optional subject :  
Optional comment :

I've just tried installing 0.17.0rc1, as well as the very latest from CVS with the same result (product is broken in ZMI Control Panel) ---

Traceback (innermost last):

  File /home/zope/lib/python/App/RefreshFuncs.py, line 182, in performSafeRefresh
  File /home/zope/lib/python/App/RefreshFuncs.py, line 169, in performRefresh
  File /home/zope/lib/python/OFS/Application.py, line 772, in reimport_product
  File /home/zope/lib/python/OFS/Application.py, line 541, in import_product
  File /home/zope/lib/python/Products/newZWiki/__init__.py, line 12, in ?
  File /home/zope/lib/python/Products/newZWiki/ZWikiPage.py, line 61, in ?
  File /home/zope/lib/python/Products/newZWiki/Fit.py, line 131, in ?
  File /home/zope/lib/python/Products/newZWiki/Fit.py, line 132, in FitSupport
  NameError: name security is not defined
I'm running Zope 2.6.1 on RH Linux 7.2

I've been using ZWiki (earlier versions) for months now with no problem, so I suspect there's some minor bug in the latest release.

good catch! --SimonMichael, 2003/03/26 19:46 GMT
I believe this will fix Fit.py :

 except ImportError:
    class FitSupport:
        security = ClassSecurityInfo() # add this

Thanks.

LarryP?, 2003/03/26 19:51 GMT
That did it! Thanks for the quick fix...