moved --admin, Thu, 24 Mar 2011 22:11:02 +0000 reply and all * sites have moved to a new VPS running zope 2.13.5. Everything should be working at this point, so please report any breakage.

Best - Simon

Hi all --frank, Sun, 26 Jun 2011 23:37:20 -0700 reply

It sure is quiet... cleaned up some vandalism, someone renamed FreeHosting. For some reason I didn't bother to look into, it broke the "new parent, name, replacement, page" form, so I did a manual rename and reverted all pages. Another thing that I learned is that a page rename apparently breaks the link with the page history; the page history remains available under the old name.

Hi all --EmmaLaurijssens, Sun, 26 Jun 2011 23:41:52 -0700 reply

...and unsubscribed umuidi4 while I was at it. A hacked Yahoo account that autoresponds with bad urls, blech.

Hi all --simon, Mon, 27 Jun 2011 06:02:54 -0700 reply

Hi Frank.. thanks.

Hi all --Simon Michael, Thu, 30 Jun 2011 13:24:48 -0700 reply

PS, thanks a lot for the cleanup help. I didn't see your first post and the extent of the spam until later.

Hi all --EmmaLaurijssens, Thu, 30 Jun 2011 13:41:32 -0700 reply

YW. It struck me as odd that I wasn't able to rename the page the 'normal' way. I didn't want to rename it from Zope as that would certainly break things so I crafted a rename URL. That worked, although it didn't rename any wikilinks. Catalog issue?

Hi all --Simon Michael, Thu, 30 Jun 2011 13:43:00 -0700 reply

Nice. What prevented ordinary renaming ? Rename button not visible ?

Hi all --Frank Laurijssens, Thu, 30 Jun 2011 13:48:32 -0700 reply

Exactly. No buttons available, to be even more exact. And it's really been a long time since I looked at the code to see how it works. :-)

Hi all --Simon Michael, Thu, 30 Jun 2011 14:02:39 -0700 reply

I looked briefly but didn't get to the bottom of it. On in the past those buttons appeared if you were authenticated or if you had a username configured in options. I still see them appearing on some pages but not consistently. Perhaps's over-aggressive apache mod_cache is causing confusion.

I noticed some explicit anonymous edit permissions granted on FreeHosting, and have removed those. I'm close to turning off anonymous edits on (following since it seems pretty much in archive mode now.

Hi all --Frank Laurijssens, Thu, 30 Jun 2011 14:07:14 -0700 reply

Yes, I was somewhat surprised about those permissions as well. I did try to remove or reset them but it didn't make any difference, so I reverted it to the previous state.

The buttons remained absent when I was logged on to Zope as well, so I figured it wasn't just a permissions issue.

thanks for the cleanup --simon, Fri, 11 Nov 2011 10:40:54 -0800 reply

Frank Laurijssens, I hereby award you the Gold Star of the Loyal Order of Wiki Defenders in recognition of your help with bot spam cleanup. Thanks for the big repair job yesterday!

Well, the time has come. I have turned off all non-authenticated edit access on, except for GeneralDiscussion where anyone with a username set in options can still add comments. One of these days I'll figure out something better to do with this site - ideas welcome.

thanks for the cleanup --EmmaLaurijssens, Fri, 11 Nov 2011 10:51:55 -0800 reply

You're welcome :-)

As I've explained before, I'm a lousy programmer, so except for the occasional bug squatting and user feedback I'm useless in projects like these otherwise ;-)

UnicodeDecoding? Error when creating a page --lww4, Fri, 02 Dec 2011 06:24:53 -0800 reply

i cannot create page named in korean. always "UnicodeDecoding? Error". how can i create a page named in non-ascii characters.

UnicodeDecoding?? Error when creating a page --simon, Sat, 03 Dec 2011 08:40:46 -0800 reply

Hi, this is supported by both Zwiki 1 and 2 I believe. has a little more detail and is an example. Use Zwiki to create the page - not the Zope Management Interface. If it still doesn't work, maybe paste the error traceback to a paste site like You can see this with bin/zopectl fg or in the .

unsubscribe --philipp, Sun, 04 Dec 2011 15:15:51 -0800 reply

Hi, how can I unsubscribe from this mailing list? Best regards, Philipp