Archived GeneralDiscussion.


Restructured Text --Nikolai, Wed, 01 Jun 2005 08:14:30 -0700 reply
I resolved this problem using a global configfile /etc/docutils.conf and setting

report_level: 5

Learning about zwikis -- Wed, 01 Jun 2005 15:46:18 -0700 reply
How do zwikis track version changes

Learning about zwikis -- Wed, 01 Jun 2005 15:47:53 -0700 reply
I saw something at DocBook? wiki . coding deletes and adds

Kongulo --DeanG, Fri, 03 Jun 2005 09:10:12 -0700 reply
Via this O'Reilly article I learned of the Python based Kongulo add-on for for the Google Windows Desktop search.

It's currently chugging along indexing a wiki with the following command line:

  kongulo --depth=1 http://wikiaddresshere/FrontPage/contents 

I had a few odd crashes but will report if it's a no-go.

Issuetracker and backlinks --EmmaLaurijssens, Sun, 05 Jun 2005 13:35:49 -0700 reply
I noticed that the backlinks page does not use the "wikilink" method to render links. This would be especially useful in case of backlinks to issuetracker pages. Is there a reason for not using wikilink?

Issuetracker and backlinks --EmmaLaurijssens, Fri, 10 Jun 2005 02:01:27 -0700 reply
I tried it ad changed:

  <a href="blurl" title=""
  tal:define="blid bl/id"
  tal:attributes="href python:here.wiki_url()+'/'+blid;
                  title bl/linkTitle|nothing;"


  tal:define="bltitle bl/Title"
  tal:replace="structure python:here.wikilink('['+bltitle+']')"

I haven't noticed any negative side effects yet. Any reason why I shouldn't be doing this?

Upgrading -- Thu, 16 Jun 2005 00:03:40 -0700 reply
I've been running a Zwiki (ver 0.9.8-1) on debian 3.0 with zope (2.5.1) without any problems. All standard precompiled stuff you'd get via apt-get. Anway, I've installed a box with the recently released debian 3.1 to test upgrading my ZWiki. I installed zope (2.6.4) and wiki (0.37.0-4) (again debian precomiled packages). I then exported my ZWiki directory, copied it to the new machine, and imported. The pages of my wiki look and work as before. However, the UserOptions?, search, subscription, etc are all broken.

I also tried moving the new ZWiki code out of the products directory and put in its place the old Zwiki code from the products directory on the old machine, reimported the ZWiki. And everything seems to work, except ZWiki has not been upgraded, the OS and Zope are new, but not the Zwiki code. To upgrade the ZWiki code, I moved the old code out of the way, and put the new zwiki code, in place, but it still breaks everything. Also, it has the old ZWiki interface, not the more recent one with the ratings, full, minimal, options etc. The upgrade page is very hard for me to understand. What is /UpgradAll? how do I run it? I've tried that from the zope interface, but it doesnt do anything or produces a not-found error.

Another thing I tried was, with new debian/zope/zwiki I created a new blank zwiki, then imported my old zwiki, and copied all of the wiki pages into the new directory, none of the dtml just my WikiPages?. But it still didn't work, because most of the pages show up blank or with weird formatting. My WikiPages? are 95% text, some pages have a little html, tables, etc just for formatting, to list data, etc but thats it.

If anyone can point me to something to read, or offer any tips, I'm in your debt.

Upgrading -- Thu, 16 Jun 2005 00:52:46 -0700 reply
Wow - daring ;)

Upgarding from Zwiki 0.9.8 2001-11-29 ... well lets see if four years of wiki development changes your wiki...

To the 'upgradeAll'

Some pages to read here for this issue would be: Installing, AdministratorsGuide (and there Upgrading) also surely worth a read are QuickReference and FAQ.

Good Luck, ArnoPucher

Thanks for responding. I have the new zope/zwiki and I freshly reimported my zwiki, and I copied each file from the directory created by the import to a newly created zwiki (excluding the dtml stuff), none of the ZWiki pages I've tried to view work, it gives me the following error:

Error Type: RuntimeError?

Error Value: Shouldn't load state for \x00\x00\x00\x00\x00\x00QG when the connection is closed

I have several images in my wiki, which reside in the wiki directory, after importing and copying over to the new directory, they can be viewed properly. Only actual zwiki pages get the above error. I tried appending the /upgradAll, but that seems to do nothing, it gives no error, nor does it change the page the browser is showing. Here is a small chunk of my z server log file:

B 163517644 2005-06-23T02:43:40 GET /NOC/ASPPlatform/
I 163517644 2005-06-23T02:43:40 0
A 163517644 2005-06-23T02:43:50 500 1606
E 163517644 2005-06-23T02:43:50
B 171783748 2005-06-23T02:43:50 GET /p/ZButton
I 171783748 2005-06-23T02:43:50 0
B 165096996 2005-06-23T02:43:50 GET /p/ZopeButton
I 165096996 2005-06-23T02:43:50 0
A 171783748 2005-06-23T02:43:50 304 313
E 171783748 2005-06-23T02:43:50
A 165096996 2005-06-23T02:43:50 304 313
E 165096996 2005-06-23T02:43:50
B 164137316 2005-06-23T02:44:03 GET /NOC/ASPPlatform/upgradeAll
I 164137316 2005-06-23T02:44:03 0
A 164137316 2005-06-23T02:44:03 500 1599
E 164137316 2005-06-23T02:44:03
B 165223492 2005-06-23T02:44:04 GET /p/ZopeButton
I 165223492 2005-06-23T02:44:04 0
B 171827796 2005-06-23T02:44:04 GET /p_/ZButton
I 171827796 2005-06-23T02:44:04 0
A 165223492 2005-06-23T02:44:04 304 313
A 171827796 2005-06-23T02:44:04 304 313
E 171827796 2005-06-23T02:44:04
E 165223492 2005-06-23T02:44:04
B 174445276 2005-06-23T02:44:32 GET /NOC/ASP-MVC-642F.JPG
I 174445276 2005-06-23T02:44:32 0
A 174445276 2005-06-23T02:44:32 200 78077
E 174445276 2005-06-23T02:44:32
B 165533764 2005-06-23T02:44:47 GET /NOC/AdvanceConfused
I 165533764 2005-06-23T02:44:47 0
A 165533764 2005-06-23T02:44:55 500 1606
E 165533764 2005-06-23T02:44:55
B 169621588 2005-06-23T02:45:05 GET /NOC/AdvanceConfused/upgradeAll
I 169621588 2005-06-23T02:45:05 0
A 169621588 2005-06-23T02:45:05 500 1603
E 169621588 2005-06-23T02:45:05
B 172011644 2005-06-23T02:45:05 GET /p/ZButton
I 172011644 2005-06-23T02:45:05 0
B 175074692 2005-06-23T02:45:05 GET /p/ZopeButton
I 175074692 2005-06-23T02:45:05 0
A 172011644 2005-06-23T02:45:05 304 313
A 175074692 2005-06-23T02:45:05 304 313
E 175074692 2005-06-23T02:45:05
E 172011644 2005-06-23T02:45:05
B 171175716 2005-06-23T02:56:20 GET /AddingNTP/setupCatalog
I 171175716 2005-06-23T02:56:20 0
A 171175716 2005-06-23T02:56:20 404 1486
E 171175716 2005-06-23T02:56:20
B 173909708 2005-06-23T02:56:27 GET /NOC/AddingNTP/setupCatalog
I 173909708 2005-06-23T02:56:27 0
A 173909708 2005-06-23T02:56:52 302 262
B 176665796 2005-06-23T02:56:52 GET /NOC/AddingNTP
I 176665796 2005-06-23T02:56:52 0
E 173909708 2005-06-23T02:56:52
A 176665796 2005-06-23T02:56:52 500 1591
E 176665796 2005-06-23T02:56:52
B 176654076 2005-06-23T02:56:52 GET /p/ZButton

Issuetracker and backlinks --EmmaLaurijssens, Thu, 16 Jun 2005 06:33:12 -0700 reply
I thought I had searched thoroughly enough, but there already was an issue for this (#1043 issue colours aren't shown in backlinks)

Issuetracker and backlinks --DeanG, Thu, 16 Jun 2005 06:35:24 -0700 reply
Would you expect the proper color to be displayed in SubTopics? also?

Issuetracker and backlinks --EmmaLaurijssens, Thu, 16 Jun 2005 08:29:54 -0700 reply
I hadn't thought about that yet... actually I hadn't thought about the Parents and Subtopics sections on the backlinks page, let alone the subtopics section on normal wiki pages. The patch suited my needs but a real patch ideally should address all of these sections.

Relative vs. Full --DeanG, Thu, 16 Jun 2005 14:05:12 -0700 reply
Is there a reason Zwiki expands the entire URL and doesn't make WikiLinks? relative?

Issuetracker and backlinks --EmmaLaurijssens, Thu, 16 Jun 2005 15:06:27 -0700 reply
Here's a redo of []?.

DTML and HTML in comments --John Grey, Fri, 24 Jun 2005 01:24:24 -0700 reply
I've set up a zwiki in which I want to allow DTML - with trusted editors only! - but I want some pages to allow anonymous comments. Just wondered if there was a way to disallow dtml (and html) in comments. thanks, John

subscribe group to a wiki page --EmmaLaurijssens, Tue, 28 Jun 2005 15:57:07 -0700 reply
I'm using a wiki page as a way to send announcements to some members of my Plone site. These members currently have been subscribed individually to the announcement page. Would it work if I put them in a group and then put the group name in subscriber_list?